# CVE-2026-34197: Apache ActiveMQ Improper Input Validation

> Authenticated attackers can achieve remote code execution on Apache ActiveMQ brokers by exploiting Jolokia MBeans to load malicious Spring XML configurations.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 16 Apr 2026 (CISA KEV)
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2026
- **Updated:** 17 Aug 2026
- **Also known as:** BIT-activemq-2026-34197, CLSA-2026-1790690736, DEBIAN-CVE-2026-34197, GHSA-rxpj-7qvf-xv32, MINI-45x5-qf32-c9vj, MINI-844g-gv3j-wwgm, MINI-f2jh-3pr8-hqpc, MINI-w2h5-xrpr-r7gr, ROOT-APP-MAVEN-CVE-2026-34197, ROOT-OS-DEBIAN-11-CVE-2026-34197, ROOT-OS-DEBIAN-12-CVE-2026-34197, ROOT-OS-DEBIAN-13-CVE-2026-34197, UBUNTU-CVE-2026-34197

## What is CVE-2026-34197?

CVE-2026-34197 is a high-severity code injection vulnerability in Apache Activemq, published on 7 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ.

Apache ActiveMQ Classic exposes the Jolokia JMX-HTTP bridge at /api/jolokia/ on the web console. The default Jolokia access policy permits exec operations on all ActiveMQ MBeans (org.apache.activemq:*), including
BrokerService.addNetworkConnector(String) and BrokerService.addConnector(String).

An authenticated attacker can invoke these operations with a crafted discovery URI that triggers the VM transport's brokerConfig parameter to load a remote Spring XML application context using ResourceXmlApplicationContext.
Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the configuration, arbitrary code execution occurs on the broker's JVM through bean factory methods such as Runtime.exec().

This issue affects Apache ActiveMQ Broker: before 5.19.4, from 6.0.0 before 6.2.3; Apache ActiveMQ All: before 5.19.4, from 6.0.0 before 6.2.3; Apache ActiveMQ: before 5.19.4, from 6.0.0 before 6.2.3.

Users are recommended to upgrade to version 5.19.4 or 6.2.3, which fixes the issue

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-94 (Improper Control of Generation of Code), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-34197?

9 open source packages ship an affected version, including org.apache.activemq:activemq-all, activemq and org.apache.activemq:activemq-broker. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.activemq:activemq-all` | Maven | All versions | 5.19.5 |
| `org.apache.activemq:activemq-all` | Maven | All versions | 5.19.5 |
| `org.apache.activemq:activemq-all` | Maven | From 6.0.0 | 6.2.3 |
| `org.apache.activemq:activemq-all` | Maven | From 6.0.0 | 6.2.3 |
| `activemq` | Bitnami | All versions | 5.19.4, 6.2.3 |
| `org.apache.activemq:activemq-broker` | Maven | All versions | 5.19.5 |
| `org.apache.activemq:activemq-broker` | Maven | All versions | 5.19.5 |
| `org.apache.activemq:activemq-broker` | Maven | From 6.0.0 | 6.2.3 |
| `org.apache.activemq:activemq-broker` | Maven | From 6.0.0 | 6.2.3 |

Products: Apache Activemq, Apache Activemq Broker.

## How do I fix CVE-2026-34197?

Upgrade org.apache.activemq:activemq-all to a fixed version for your release line: 5.19.5 or 6.2.3. US federal agencies must fix it by 30 Apr 2026.

## Is CVE-2026-34197 being exploited?

Yes. Attackers have exploited CVE-2026-34197 in the wild since at least 16 Apr 2026.

Public exploit code:

- Apache ActiveMQ漏洞综合利用工具(CVE-2015-5254，CVE-2016-3088，CVE-2022-41678，CVE-2023-46604，CVE-2024-32114，CVE-2026-34197，CVE-2026-40466， CVE-2026-42588) (github_poc): https://github.com/Catherines77/ActiveMQ-EXPtools
- Apache ActiveMQ Classic RCE research: CVE-2026-34197 / CVE-2026-42588 bypass chain + hardened-6.2.6 audit findings + Crowdfense comparison  (github_poc): https://github.com/dinosn/apache-activemq-rce-research
- CVE-2026-34197 activemq PoC (github_poc): https://github.com/dinosn/CVE-2026-34197
- CVE-2026-34197 - Apache ActiveMQ RCE via Jolokia Endpoint PoC (github_poc): https://github.com/DEVSECURITYSPRO/CVE-2026-34197
- CVE-2026-34197 (github_poc): https://github.com/AtoposX-J/CVE-2026-34197-Apache-ActiveMQ-RCE
- CVE-2026-34197 — Apache ActiveMQ RCE via Jolokia API | PoC Exploit (github_poc): https://github.com/KONDORDEVSECURITYCORP/CVE-2026-34197

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)
- [CVE-2014-3600](https://insights.sbomify.com/CVE-2014-3600/): Improper Restriction of XML External Entity Reference in Apache ActiveMQ (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34197 and fix it if it is affected.

What it is: CVE-2026-34197 is a high-severity code injection vulnerability in Apache Activemq, published on 7 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2026-34197 in the wild since at least 16 Apr 2026.

Affected packages and fixed versions:
- org.apache.activemq:activemq-all (Maven): affected all versions; fixed in 5.19.5
- org.apache.activemq:activemq-all (Maven): affected all versions; fixed in 5.19.5
- org.apache.activemq:activemq-all (Maven): affected from 6.0.0; fixed in 6.2.3
- org.apache.activemq:activemq-all (Maven): affected from 6.0.0; fixed in 6.2.3
- activemq (Bitnami): affected all versions; fixed in 5.19.4, 6.2.3
- org.apache.activemq:activemq-broker (Maven): affected all versions; fixed in 5.19.5
- org.apache.activemq:activemq-broker (Maven): affected all versions; fixed in 5.19.5
- org.apache.activemq:activemq-broker (Maven): affected from 6.0.0; fixed in 6.2.3
- org.apache.activemq:activemq-broker (Maven): affected from 6.0.0; fixed in 6.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34197/ (Markdown: https://insights.sbomify.com/CVE-2026-34197/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34197
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34197
- OSV: https://osv.dev/vulnerability/CVE-2026-34197

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34197/
Summaries are generated and may contain mistakes; the official description above is the record.
