# CVE-2026-34203: Nautobot: Management of users via REST API does not apply configured password validators

> Attackers can create or modify users with weak passwords via REST API, bypassing configured password validation rules in Nautobot.

- **Severity:** Low 2.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Mar 2026
- **Updated:** 31 Mar 2026
- **Also known as:** GHSA-xmpv-j7p2-j873, PYSEC-2026-2224

## What is CVE-2026-34203?

CVE-2026-34203 is a low-severity vulnerability in nautobot, published on 31 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Nautobot is a Network Source of Truth and Network Automation Platform. Prior to versions 2.4.30 and 3.0.10, user creation and editing via the REST API fails to apply the password validation rules defined by Django's AUTH_PASSWORD_VALIDATORS setting (which defaults to an empty list, i.e., no specific rules, but can be configured in Nautobot's nautobot_config.py to apply various rules if desired). This can potentially allow for the creation or modification of users to have passwords that are weak or otherwise do not comply with configured standards. This issue has been patched in versions 2.4.30 and 3.0.10.

Weakness: CWE-521 (Weak Password Requirements)

## Which versions are affected by CVE-2026-34203?

5 open source packages ship an affected version, including nautobot. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nautobot` | PyPI | All versions | 2.4.30, 3.0.10 |
| `nautobot` | PyPI | All versions | 2.4.30 |
| `nautobot` | PyPI | All versions | 2.4.30 |
| `nautobot` | PyPI | From 3.0.0 | 3.0.10 |
| `nautobot` | PyPI | From 3.0.0 | 3.0.10 |

Products: Networktocode Nautobot.

## How do I fix CVE-2026-34203?

Upgrade nautobot to a fixed version for your release line: 2.4.30 or 3.0.10.

## Is CVE-2026-34203 being exploited?

There is no known exploitation of CVE-2026-34203 in the wild and no public exploit code.

## Other vulnerabilities in nautobot

- [CVE-2026-44797](https://insights.sbomify.com/CVE-2026-44797/): Nautobot: Webhook definitions could be used for server-side request forgery (SSRF) (high 8.5)
- [CVE-2024-34707](https://insights.sbomify.com/CVE-2024-34707/): Nautobot's BANNER_* configuration can be used to inject arbitrary HTML content into Nautobot pages (high 7.5)
- [CVE-2024-32979](https://insights.sbomify.com/CVE-2024-32979/): Reflected Cross-site Scripting potential in all object list views in Nautobot (high 7.5)
- [CVE-2023-25657](https://insights.sbomify.com/CVE-2023-25657/): Remote code execution in Jinja2 template rendering in Nautobot (high 7.5)
- [CVE-2026-44798](https://insights.sbomify.com/CVE-2026-44798/): Nautobot: GitRepository.current_head field should not be writable through REST API (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34203 and fix it if it is affected.

What it is: CVE-2026-34203 is a low-severity vulnerability in nautobot, published on 31 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-34203 in the wild and no public exploit code.

Affected packages and fixed versions:
- nautobot (PyPI): affected all versions; fixed in 2.4.30, 3.0.10
- nautobot (PyPI): affected all versions; fixed in 2.4.30
- nautobot (PyPI): affected all versions; fixed in 2.4.30
- nautobot (PyPI): affected from 3.0.0; fixed in 3.0.10
- nautobot (PyPI): affected from 3.0.0; fixed in 3.0.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34203/ (Markdown: https://insights.sbomify.com/CVE-2026-34203/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34203
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34203
- OSV: https://osv.dev/vulnerability/CVE-2026-34203

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34203/
Summaries are generated and may contain mistakes; the official description above is the record.
