# CVE-2026-34230: Rack: Quadratic complexity in Rack::Utils.select_best_encoding via wildcard Accept-Encoding header

> An unauthenticated attacker can cause denial of service in Rack applications using Deflater by sending a crafted Accept-Encoding header with many wildcards.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Apr 2026
- **Updated:** 3 Apr 2026
- **Also known as:** DEBIAN-CVE-2026-34230, GHSA-v569-hp3g-36wr, MINI-24h4-c8xf-m83x, MINI-2533-8cmf-xvhf, MINI-3gxq-x68c-6cq4, MINI-4r8r-xhc6-9q4f, MINI-7cff-q82h-vq42, MINI-7rcg-qpm6-r4fj, MINI-88j2-r4c9-wxqm, MINI-88pc-5qrf-pjg6, MINI-cg59-rpj5-pj6p, MINI-fx92-cf4v-cvrv, MINI-hc4r-qpm6-j34h, MINI-hgh8-7m8v-3fg6, MINI-jg2p-q9cg-f939, MINI-m2fx-7gv4-25m7, MINI-pg5x-m587-h7cx, MINI-qm53-4jwr-f33v, MINI-qpxq-mfw3-q9xr, MINI-v2pc-rwjw-wfp3, MINI-vx88-g4cv-849h, MINI-w77g-rj6g-4q58, MINI-w8r6-gf43-m8cw, MINI-wwcf-mff3-7ggj, MINI-x455-266f-vm3q, MINI-xjc4-5hwf-w4g8, UBUNTU-CVE-2026-34230

## What is CVE-2026-34230?

CVE-2026-34230 is a medium-severity denial of service vulnerability in rack, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Rack is a modular Ruby web server interface. Prior to versions 2.2.23, 3.1.21, and 3.2.6, Rack::Utils.select_best_encoding processes Accept-Encoding values with quadratic time complexity when the header contains many wildcard (*) entries. Because this method is used by Rack::Deflater to choose a response encoding, an unauthenticated attacker can send a single request with a crafted Accept-Encoding header and cause disproportionate CPU consumption on the compression middleware path. This results in a denial of service condition for applications using Rack::Deflater. This issue has been patched in versions 2.2.23, 3.1.21, and 3.2.6.

Weakness: CWE-407 (Inefficient Algorithmic Complexity), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-34230?

6 open source packages ship an affected version, including rack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rack` | RubyGems | All versions | 2.2.23 |
| `rack` | RubyGems | All versions | 2.2.23 |
| `rack` | RubyGems | From 3.0.0.beta1 | 3.1.21 |
| `rack` | RubyGems | From 3.0.0.beta1 | 3.1.21 |
| `rack` | RubyGems | From 3.2.0 | 3.2.6 |
| `rack` | RubyGems | From 3.2.0 | 3.2.6 |

Products: Rack Rack.

## How do I fix CVE-2026-34230?

Upgrade rack to a fixed version for your release line: 2.2.23, 3.1.21 or 3.2.6.

## Is CVE-2026-34230 being exploited?

There is no known exploitation of CVE-2026-34230 in the wild and no public exploit code.

## Other vulnerabilities in rack

- [CVE-2026-34785](https://insights.sbomify.com/CVE-2026-34785/): Rack: Local file inclusion in `Rack::Static` via URL Prefix Matching (high 7.5)
- [CVE-2026-34827](https://insights.sbomify.com/CVE-2026-34827/): Rack: Algorithmic-Complexity DoS in Rack::Multipart::Parser (high 7.5)
- [CVE-2026-34829](https://insights.sbomify.com/CVE-2026-34829/): Rack: Denial of Service via Unbounded Multipart File Upload Without Content-Length (high 7.5)
- [CVE-2026-22860](https://insights.sbomify.com/CVE-2026-22860/): Rack has a Directory Traversal via Rack:Directory (high 7.5)
- [CVE-2025-61919](https://insights.sbomify.com/CVE-2025-61919/): Rack is vulnerable to a memory-exhaustion DoS through unbounded URL-encoded body parsing (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34230 and fix it if it is affected.

What it is: CVE-2026-34230 is a medium-severity denial of service vulnerability in rack, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-34230 in the wild and no public exploit code.

Affected packages and fixed versions:
- rack (RubyGems): affected all versions; fixed in 2.2.23
- rack (RubyGems): affected all versions; fixed in 2.2.23
- rack (RubyGems): affected from 3.0.0.beta1; fixed in 3.1.21
- rack (RubyGems): affected from 3.0.0.beta1; fixed in 3.1.21
- rack (RubyGems): affected from 3.2.0; fixed in 3.2.6
- rack (RubyGems): affected from 3.2.0; fixed in 3.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34230/ (Markdown: https://insights.sbomify.com/CVE-2026-34230/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34230
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34230
- OSV: https://osv.dev/vulnerability/CVE-2026-34230

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34230/
Summaries are generated and may contain mistakes; the official description above is the record.
