{"answers":{"affected":"3 open source packages ship an affected version, including slippers. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-34231 in the wild and no public exploit code.","fix":"Upgrade slippers to 0.6.3 or later.","what":"CVE-2026-34231 is a medium-severity cross-site scripting vulnerability in mixxorz slippers, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-34231 and fix it if it is affected.\n\nWhat it is: CVE-2026-34231 is a medium-severity cross-site scripting vulnerability in mixxorz slippers, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-34231 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- slippers (PyPI): affected all versions; fixed in 0.6.3\n- slippers (PyPI): affected all versions; fixed in 0.6.3\n- slippers (PyPI): affected all versions; fixed in 0.6.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-34231/ (Markdown: https://insights.sbomify.com/CVE-2026-34231/index.md)","id":"CVE-2026-34231","markdown":"https://insights.sbomify.com/CVE-2026-34231/index.md","name":"CVE-2026-34231","record":{"aliases":["GHSA-w7rv-gfp4-j9j3","PYSEC-2026-2279"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Django UI framework","requires_auth":"none","summary":"Attackers can inject arbitrary JavaScript via unescaped attributes in the Slippers Django framework, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"slippers","vendor":"django"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Slippers is a UI component framework for Django. Prior to version 0.6.3, a Cross-Site Scripting (XSS) vulnerability exists in the {% attrs %} template tag of the slippers Django package. When a context variable containing untrusted data is passed to {% attrs %}, the value is interpolated into an HTML attribute string without escaping, allowing an attacker to break out of the attribute context and inject arbitrary HTML or JavaScript into the rendered page. This issue has been patched in version 0.6.3.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Slippers: Cross-Site Scripting (XSS) in `attrs` Template Tag","id":"CVE-2026-34231","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"Firebird: DoS via `op_response` packet from client","id":"CVE-2026-34232"},"packages":[{"ecosystem":"PyPI","fixed":["0.6.3"],"introduced":["0"],"last_affected":[],"package":"slippers","purl":null,"source":"GHSA-w7rv-gfp4-j9j3"},{"ecosystem":"PyPI","fixed":["0.6.3"],"introduced":["0"],"last_affected":[],"package":"slippers","purl":"pkg:pypi/slippers","source":"GHSA-w7rv-gfp4-j9j3"},{"ecosystem":"PyPI","fixed":["0.6.3"],"introduced":["0"],"last_affected":[],"package":"slippers","purl":"pkg:pypi/slippers","source":"PYSEC-2026-2279"}],"prev":{"headline":"Rack: Quadratic complexity in Rack::Utils.select_best_encoding via wildcard Accept-Encoding header","id":"CVE-2026-34230"},"products":["slippers"],"published":"2026-03-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-31","vendors":["mixxorz"]},"summary":"Attackers can inject arbitrary JavaScript via unescaped attributes in the Slippers Django framework, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2026-34231/"}