# CVE-2026-34231: Slippers: Cross-Site Scripting (XSS) in `attrs` Template Tag

> Attackers can inject arbitrary JavaScript via unescaped attributes in the Slippers Django framework, potentially compromising user sessions.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Mar 2026
- **Updated:** 31 Mar 2026
- **Also known as:** GHSA-w7rv-gfp4-j9j3, PYSEC-2026-2279

## What is CVE-2026-34231?

CVE-2026-34231 is a medium-severity cross-site scripting vulnerability in mixxorz slippers, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Slippers is a UI component framework for Django. Prior to version 0.6.3, a Cross-Site Scripting (XSS) vulnerability exists in the {% attrs %} template tag of the slippers Django package. When a context variable containing untrusted data is passed to {% attrs %}, the value is interpolated into an HTML attribute string without escaping, allowing an attacker to break out of the attribute context and inject arbitrary HTML or JavaScript into the rendered page. This issue has been patched in version 0.6.3.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-34231?

3 open source packages ship an affected version, including slippers. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `slippers` | PyPI | All versions | 0.6.3 |
| `slippers` | PyPI | All versions | 0.6.3 |
| `slippers` | PyPI | All versions | 0.6.3 |

Products: Django Slippers.

## How do I fix CVE-2026-34231?

Upgrade slippers to 0.6.3 or later.

## Is CVE-2026-34231 being exploited?

There is no known exploitation of CVE-2026-34231 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34231 and fix it if it is affected.

What it is: CVE-2026-34231 is a medium-severity cross-site scripting vulnerability in mixxorz slippers, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-34231 in the wild and no public exploit code.

Affected packages and fixed versions:
- slippers (PyPI): affected all versions; fixed in 0.6.3
- slippers (PyPI): affected all versions; fixed in 0.6.3
- slippers (PyPI): affected all versions; fixed in 0.6.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34231/ (Markdown: https://insights.sbomify.com/CVE-2026-34231/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34231
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34231
- OSV: https://osv.dev/vulnerability/CVE-2026-34231

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34231/
Summaries are generated and may contain mistakes; the official description above is the record.
