# CVE-2026-34235: PJSIP: Heap OOB read in VPX unpacketizer

> A heap out-of-bounds read in PJSIP's VP9 unpacketizer allows attackers to cause crashes or disclose memory via crafted RTP packets.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Mar 2026
- **Updated:** 2 Apr 2026
- **Also known as:** ALPINE-CVE-2026-34235, DEBIAN-CVE-2026-34235, GHSA-pqrm-53pc-wx28, UBUNTU-CVE-2026-34235

## What is CVE-2026-34235?

CVE-2026-34235 is a medium-severity memory corruption vulnerability in pjsip pjproject, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PJSIP is a free and open source multimedia communication library written in C. Prior to version 2.17, a heap out-of-bounds read vulnerability exists in PJSIP's VP9 RTP unpacketizer that occurs when parsing crafted VP9 Scalability Structure (SS) data. Insufficient bounds checking on the payload descriptor length may cause reads beyond the allocated RTP payload buffer. This issue has been patched in version 2.17. A workaround for this issue involves disabling VP9 codec if not needed.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-34235?

It affects 1 product.


Products: Teluu Pjsip.

## How do I fix CVE-2026-34235?

Upgrade to a fixed version.

## Is CVE-2026-34235 being exploited?

There is no known exploitation of CVE-2026-34235 in the wild and no public exploit code.

## Other vulnerabilities in pjsip pjproject

- [CVE-2023-38703](https://insights.sbomify.com/CVE-2023-38703/): PJSIP has use-after-free vulnerability in SRTP media transport (critical 9.8)
- [CVE-2022-39269](https://insights.sbomify.com/CVE-2022-39269/): Media transport downgrade from the secure version (SRTP) to non-secure (RTP) in pjsip (critical 9.1)
- [CVE-2026-57161](https://insights.sbomify.com/CVE-2026-57161/): PJSIP: Stack overflow handling Service-Route headers in a registration response (high 8.8)
- [CVE-2026-57162](https://insights.sbomify.com/CVE-2026-57162/): PJSIP: Stack overflow parsing SDP a=crypto attributes (high 8.8)
- [CVE-2026-57163](https://insights.sbomify.com/CVE-2026-57163/): PJSIP: Stack overflow parsing a TLS peer certificate's SubjectAltName in GnuTLS backend (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34235 and fix it if it is affected.

What it is: CVE-2026-34235 is a medium-severity memory corruption vulnerability in pjsip pjproject, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-34235 in the wild and no public exploit code.

Affected product: pjsip pjproject. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34235/ (Markdown: https://insights.sbomify.com/CVE-2026-34235/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34235
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34235
- OSV: https://osv.dev/vulnerability/CVE-2026-34235

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34235/
Summaries are generated and may contain mistakes; the official description above is the record.
