CVE-2026-34236 Auth0 PHP SDK Insufficient Entropy in Cookie Encryption

High 8.2 Published Updated

Attackers can brute-force encryption keys to forge session cookies, leading to account takeover in applications using the Auth0 PHP SDK.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-34236?

CVE-2026-34236 is a high-severity vulnerability in auth0-PHP, published on 1 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Auth0-PHP is a PHP SDK for Auth0 Authentication and Management APIs. From version 8.0.0 to before version 8.19.0, in applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies. This issue has been patched in version 8.19.0.

Weakness: CWE-331

Which versions are affected by CVE-2026-34236?

2 open source packages ship an affected version, including auth0/auth0-php. It affects 1 product.

PackageAffectedFixed in
auth0/auth0-php PackagistFrom 8.0.08.19.0
auth0/auth0-php PackagistFrom 8.0.08.19.0

Products include Auth0 Auth0-Php.

How do I fix CVE-2026-34236?

Upgrade auth0/auth0-php to 8.19.0 or later.

Is CVE-2026-34236 being exploited?

There is no known exploitation of CVE-2026-34236 in the wild and no public exploit code.

Sources

Also known as GHSA-w3wc-44p4-m4j7.

Is CVE-2026-34236 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free