{"answers":{"affected":"2 open source packages ship an affected version, including auth0/auth0-php. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-34236 in the wild and no public exploit code.","fix":"Upgrade auth0/auth0-php to 8.19.0 or later.","what":"CVE-2026-34236 is a high-severity vulnerability in auth0-PHP, published on 1 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-34236 and fix it if it is affected.\n\nWhat it is: CVE-2026-34236 is a high-severity vulnerability in auth0-PHP, published on 1 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-34236 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- auth0/auth0-php (Packagist): affected from 8.0.0; fixed in 8.19.0\n- auth0/auth0-php (Packagist): affected from 8.0.0; fixed in 8.19.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-34236/ (Markdown: https://insights.sbomify.com/CVE-2026-34236/index.md)","id":"CVE-2026-34236","markdown":"https://insights.sbomify.com/CVE-2026-34236/index.md","name":"CVE-2026-34236","record":{"aliases":["GHSA-w3wc-44p4-m4j7"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Auth0 PHP SDK","requires_auth":"low_privilege","summary":"Attackers can brute-force encryption keys to forge session cookies, leading to account takeover in applications using the Auth0 PHP SDK.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"auth0-php","vendor":"auth0"}],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-331","name":"Insufficient Entropy"}],"description":"Auth0-PHP is a PHP SDK for Auth0 Authentication and Management APIs. From version 8.0.0 to before version 8.19.0, in applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies. This issue has been patched in version 8.19.0.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Auth0 PHP SDK Insufficient Entropy in Cookie Encryption","id":"CVE-2026-34236","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"weak_cryptography","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"MCP Java SDK has a Hardcoded Wildcard CORS (Access-Control-Allow-Origin: *)","id":"CVE-2026-34237"},"packages":[{"ecosystem":"Packagist","fixed":["8.19.0"],"introduced":["8.0.0"],"last_affected":[],"package":"auth0/auth0-php","purl":null,"source":"GHSA-w3wc-44p4-m4j7"},{"ecosystem":"Packagist","fixed":["8.19.0"],"introduced":["8.0.0"],"last_affected":[],"package":"auth0/auth0-php","purl":"pkg:composer/auth0/auth0-php","source":"GHSA-w3wc-44p4-m4j7"}],"prev":{"headline":"PJSIP: Heap OOB read in VPX unpacketizer","id":"CVE-2026-34235"},"products":["auth0-PHP"],"published":"2026-04-01","related":[{"cvss_score":6.8,"headline":"Auth0-PHP SDK has Improper Audience Validation","id":"CVE-2025-68129","kev_date_added":null,"published":"2025-12-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-01","vendors":["auth0"]},"summary":"Attackers can brute-force encryption keys to forge session cookies, leading to account takeover in applications using the Auth0 PHP SDK.","url":"https://insights.sbomify.com/CVE-2026-34236/"}