# CVE-2026-3429: Keycloak: Improper Access Control Leading to MFA Deletion and Account Takeover in Keycloak Account REST API

> An attacker with a victim's password can bypass MFA checks to delete existing credentials and register their own, leading to full account takeover.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Mar 2026
- **Updated:** 2 Apr 2026
- **Also known as:** BIT-keycloak-2026-3429, ECHO-a685-7f88-c69b, GHSA-8g9r-9wjw-37j4, MINI-8w2p-rqvv-j7xm, MINI-gg69-g8c9-37mv

## What is CVE-2026-3429?

CVE-2026-3429 is a medium-severity missing authorization vulnerability in Redhat Build of Keycloak, published on 11 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was identified in the Account REST API of Keycloak that allows a user authenticated at a lower security level to perform sensitive actions intended only for higher-assurance sessions. Specifically, an attacker who has already obtained a victim’s password can delete the victim’s registered MFA/OTP credential without first proving possession of that factor. The attacker can then register their own MFA device, effectively taking full control of the account. This weakness undermines the intended protection provided by multi-factor authentication.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-3429?

3 open source packages ship an affected version, including org.keycloak:keycloak-services and keycloak. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-services` | Maven | All versions to 26.5.6 | None |
| `org.keycloak:keycloak-services` | Maven | All versions to 26.5.6 | None |
| `keycloak` | Bitnami | From 26.4.0 | 26.4.11 |

Products: Redhat Build of Keycloak.

## How do I fix CVE-2026-3429?

Apply the vendor's patch.

## Is CVE-2026-3429 being exploited?

There is no known exploitation of CVE-2026-3429 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Build of Keycloak

- [CVE-2026-15572](https://insights.sbomify.com/CVE-2026-15572/): Keycloak-services: keycloak-services: dcr protocol mapper type-swap policy bypass allows privilege escalation (high 8.8)
- [CVE-2026-3047](https://insights.sbomify.com/CVE-2026-3047/): Keycloak SAML Broken has Authentication Bypass by Primary Weakness (high 8.8)
- [CVE-2026-15573](https://insights.sbomify.com/CVE-2026-15573/): Keycloak-services: keycloak-services: authorization bypass via unnormalized uri matching in pathmatcher (high 8.1)
- [CVE-2026-16102](https://insights.sbomify.com/CVE-2026-16102/): Keycloak-services: keycloak-services: default dcr policy allows role forgery via user property mappers (high 8.1)
- [CVE-2026-1609](https://insights.sbomify.com/CVE-2026-1609/): Org.keycloak/keycloak-quarkus-server: keycloak: unauthorized access via jwt authorization grant with disabled users (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-3429 and fix it if it is affected.

What it is: CVE-2026-3429 is a medium-severity missing authorization vulnerability in Redhat Build of Keycloak, published on 11 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-3429 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-services (Maven): affected all versions up to 26.5.6; no fix listed
- org.keycloak:keycloak-services (Maven): affected all versions up to 26.5.6; no fix listed
- keycloak (Bitnami): affected from 26.4.0; fixed in 26.4.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-3429/ (Markdown: https://insights.sbomify.com/CVE-2026-3429/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-3429
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-3429
- OSV: https://osv.dev/vulnerability/CVE-2026-3429

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-3429/
Summaries are generated and may contain mistakes; the official description above is the record.
