CVE-2026-3433 Mattermost fails to scope role_updated websocket events to authorized team and channel members

Medium 4.3 Published Updated

An authenticated guest can observe private team permission changes via websocket events, leaking sensitive configuration data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-3433?

CVE-2026-3433 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 12 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Mattermost versions 11.6.x <= 11.6.1, 11.5.x <= 11.5.4, 10.11.x <= 10.11.15, 10.11.x <= 10.11.16 fail to restrict role_updated websocket event broadcasts to members of the affected team or channel which allows an authenticated attacker with guest-level access to observe permission scheme change notifications for private teams they are not a member of via the websocket connection.. Mattermost Advisory ID: MMSA-2026-00616

Weakness: CWE-200

Which versions are affected by CVE-2026-3433?

12 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost-server GoFrom 10.11.010.11.17
github.com/mattermost/mattermost-server GoFrom 10.11.010.11.17
github.com/mattermost/mattermost-server GoFrom 10.11.0+incompatible10.11.17+incompatible, 11.5.5+incompatible, 11.6.1+incompatible
github.com/mattermost/mattermost-server GoFrom 11.5.011.5.5
github.com/mattermost/mattermost-server GoFrom 11.5.011.5.5
github.com/mattermost/mattermost-server GoFrom 11.6.011.6.1
6 more packages
github.com/mattermost/mattermost-server GoFrom 11.6.011.6.1
github.com/mattermost/mattermost-server/v5 GoAll versionsNone
github.com/mattermost/mattermost-server/v6 GoAll versionsNone
github.com/mattermost/mattermost/server/v8 GoFrom 8.0.0-20250731163400-5b955468ea1e8.0.0-20260504071740-9408b98025d7
github.com/mattermost/mattermost/server/v8 GoFrom 8.0.0-20250731163400-5b955468ea1e8.0.0-20260504071740-9408b98025d7
github.com/mattermost/mattermost/server/v8 GoFrom 8.0.0-20250731163400-5b955468ea1e8.0.0-20260504071740-9408b98025d7

Products include Mattermost Mattermost Server.

How do I fix CVE-2026-3433?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.17, 10.11.17+incompatible, 11.5.5+incompatible or 11.6.1+incompatible.

Is CVE-2026-3433 being exploited?

There is no known exploitation of CVE-2026-3433 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as GHSA-rp4v-qc77-phm4, GO-2026-6286.

Is CVE-2026-3433 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free