CVE-2026-34355 Apache HTTP Server: mod_proxy_html buffer overflow
An untrusted backend can trigger a buffer overflow in mod_proxy_html, potentially leading to code execution or denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-34355?
CVE-2026-34355 is a high-severity memory corruption vulnerability in Apache Http Server, published on 8 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A buffer overflow in mod_proxy_html in Apache HTTP Server 2.4.67 and earlier allows an attack by an untrusted backend. Users are recommended to upgrade to version 2.4.68, which fixes this issue.
Which versions are affected by CVE-2026-34355?
1 open source package ship an affected version, including apache. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache Bitnami | From 2.4.0 | 2.4.68 |
Products include Apache Http Server.
How do I fix CVE-2026-34355?
Upgrade apache to 2.4.68 or later.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2026-34355 being exploited?
There is no known exploitation of CVE-2026-34355 in the wild and no public exploit code.
Other vulnerabilities in Apache Http Server
Sources
Also known as ALPINE-CVE-2026-34355, AZL-89750, BELL-CVE-2026-34355, BIT-apache-2026-34355, DEBIAN-CVE-2026-34355, ECHO-a5e9-c007-e46c and 3 more.