CVE-2026-34356 Apache HTTP Server: ProxyPassReverseCookieMap buffer overflow
A heap-based buffer overflow in Apache HTTP Server allows attackers with control over backend servers to execute code or cause denial of service via ProxyPassReverseCookieMap.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-34356?
CVE-2026-34356 is a high-severity memory corruption vulnerability in Apache Http Server, published on 8 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Heap-based Buffer Overflow vulnerability in Apache HTTP Server with malicious backend servers and ProxyPassReverseCookie*
This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67.
Users are recommended to upgrade to version 2.4.68, which fixes the issue.
Weakness: CWE-122
Which versions are affected by CVE-2026-34356?
1 open source package ship an affected version, including apache. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache Bitnami | From 2.4.0 | 2.4.68 |
Products include Apache Http Server.
How do I fix CVE-2026-34356?
Upgrade apache to 2.4.68 or later.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2026-34356 being exploited?
There is no known exploitation of CVE-2026-34356 in the wild and no public exploit code.
Other vulnerabilities in Apache Http Server
Sources
Also known as ALPINE-CVE-2026-34356, AZL-89744, BELL-CVE-2026-34356, BIT-apache-2026-34356, DEBIAN-CVE-2026-34356, ECHO-4833-98fe-e642 and 3 more.