# CVE-2026-34359: HAPI FHIR: Authentication Credential Leakage via Improper URL Prefix Matching on HTTP Redirect in HAPI FHIR Core

> Attackers can steal authentication credentials by exploiting improper URL prefix matching during HTTP redirects in the HAPI FHIR library.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Mar 2026
- **Updated:** 31 Mar 2026
- **Also known as:** GHSA-fgv2-4q4g-wc35, ROOT-APP-MAVEN-CVE-2026-34359

## What is CVE-2026-34359?

CVE-2026-34359 is a high-severity vulnerability in hapifhir org.hl7.fhir.core, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HAPI FHIR is a complete implementation of the HL7 FHIR standard for healthcare interoperability in Java. Prior to version 6.9.4, ManagedWebAccessUtils.getServer() uses String.startsWith() to match request URLs against configured server URLs for authentication credential dispatch. Because configured server URLs (e.g., http://tx.fhir.org) lack a trailing slash or host boundary check, an attacker-controlled domain like http://tx.fhir.org.attacker.com matches the prefix and receives Bearer tokens, Basic auth credentials, or API keys when the HTTP client follows a redirect to that domain. This issue has been patched in version 6.9.4.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2026-34359?

4 open source packages ship an affected version, including ca.uhn.hapi.fhir:org.hl7.fhir.core and ca.uhn.hapi.fhir:org.hl7.fhir.utilities. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ca.uhn.hapi.fhir:org.hl7.fhir.core` | Maven | All versions | 6.9.4 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.core` | Maven | All versions | 6.9.4 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.utilities` | Maven | All versions | 6.9.4 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.utilities` | Maven | All versions | 6.9.4 |

Products: Hapifhir Hl7 Fhir Core.

## How do I fix CVE-2026-34359?

Upgrade ca.uhn.hapi.fhir:org.hl7.fhir.core to 6.9.4 or later.

## Is CVE-2026-34359 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34359 exists.

## Other vulnerabilities in hapifhir org.hl7.fhir.core

- [CVE-2026-34361](https://insights.sbomify.com/CVE-2026-34361/): HAPI FHIR: Unauthenticated SSRF via /loadIG Chains with startsWith() Credential Leak for Authentication Token Theft (critical 9.3)
- [CVE-2026-55471](https://insights.sbomify.com/CVE-2026-55471/): HAPI FHIR: XXE in XsltUtilities.saxonTransform via unhardened Saxon TransformerFactory (high 8.7)
- [CVE-2023-24057](https://insights.sbomify.com/CVE-2023-24057/): MITM based Zip Slip in `ca.uhn.hapi.fhir:org.hl7.fhir.core` (high 8.1)
- [CVE-2026-55470](https://insights.sbomify.com/CVE-2026-55470/): HAPI FHIR: DSTU2 FHIRPathEngine.matches() missing RegexTimeout protection allows ReDoS (high 7.5)
- [CVE-2023-28465](https://insights.sbomify.com/CVE-2023-28465/): HL7 FHIR Partial Path Zip Slip due to bypass of CVE-2023-24057 (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34359 and fix it if it is affected.

What it is: CVE-2026-34359 is a high-severity vulnerability in hapifhir org.hl7.fhir.core, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34359 exists.

Affected packages and fixed versions:
- ca.uhn.hapi.fhir:org.hl7.fhir.core (Maven): affected all versions; fixed in 6.9.4
- ca.uhn.hapi.fhir:org.hl7.fhir.core (Maven): affected all versions; fixed in 6.9.4
- ca.uhn.hapi.fhir:org.hl7.fhir.utilities (Maven): affected all versions; fixed in 6.9.4
- ca.uhn.hapi.fhir:org.hl7.fhir.utilities (Maven): affected all versions; fixed in 6.9.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34359/ (Markdown: https://insights.sbomify.com/CVE-2026-34359/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34359
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34359
- OSV: https://osv.dev/vulnerability/CVE-2026-34359

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34359/
Summaries are generated and may contain mistakes; the official description above is the record.
