CVE-2026-34363 Parse Server: LiveQuery protected field leak via shared mutable state across concurrent subscribers
Concurrent LiveQuery subscribers may leak protected fields or authentication data due to shared mutable state in event handlers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-34363?
CVE-2026-34363 is a high-severity vulnerability in Parseplatform Parse-Server, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.65 and 9.7.0-alpha.9, when multiple clients subscribe to the same class via LiveQuery, the event handlers process each subscriber concurrently using shared mutable objects. The sensitive data filter modifies these shared objects in-place, so when one subscriber's filter removes a protected field, subsequent subscribers may receive the already-filtered object. This can cause protected fields and authentication data to leak to clients that should not see them, or cause clients that should see the data to receive an incomplete object. Additionally, when an afterEvent Cloud Code trigger is registered, one subscriber's trigger modifications can leak to other subscribers through the same shared mutable state. Any Parse Server deployment using LiveQuery with protected fields or afterEvent triggers is affected when multiple clients subscribe to the same class. This issue has been patched in versions 8.6.65 and 9.7.0-alpha.9.
Weakness: CWE-362
Which versions are affected by CVE-2026-34363?
5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
parse-server npm | All versions | 8.6.65 |
parse-server npm | All versions | 8.6.65 |
parse-server npm | From 9.0.0 | 9.7.0-alpha.9 |
parse-server npm | From 9.0.0 | 9.7.0-alpha.9 |
parse Bitnami | All versions | 8.6.65, 9.7.0 |
Products include Parseplatform Parse-Server.
How do I fix CVE-2026-34363?
Upgrade parse-server to a fixed version for your release line: 8.6.65 or 9.7.0-alpha.9.
Is CVE-2026-34363 being exploited?
There is no known exploitation of CVE-2026-34363 in the wild and no public exploit code.
Other vulnerabilities in Parseplatform Parse-Server
- CVE-2026-30966 Parse Server role escalation and CLP bypass via direct `_Join` table write
- CVE-2024-27298 Parse Server literalizeRegexPart SQL Injection
- CVE-2022-24760 Command Injection in Parse server
- CVE-2026-30965 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter
- CVE-2023-36475 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution
Sources
Also known as BIT-parse-2026-34363, GHSA-m983-v2ff-wq65.