# CVE-2026-34373: Parse Server: GraphQL API endpoint ignores CORS origin restriction

> Parse Server GraphQL endpoint ignores CORS origin restrictions, allowing unauthorized cross-origin requests when operators configure specific origin limits.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Mar 2026
- **Updated:** 31 Mar 2026
- **Also known as:** BIT-parse-2026-34373, GHSA-q3p6-g7c4-829c

## What is CVE-2026-34373?

CVE-2026-34373 is a medium-severity vulnerability in Parseplatform Parse-Server, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.66 and 9.7.0-alpha.10, the GraphQL API endpoint does not respect the allowOrigin server option and unconditionally allows cross-origin requests from any website. This bypasses origin restrictions that operators configure to control which websites can interact with the Parse Server API. The REST API correctly enforces the configured allowOrigin restriction. This issue has been patched in versions 8.6.66 and 9.7.0-alpha.10.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2026-34373?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | From 3.5.0 | 8.6.66 |
| `parse-server` | npm | From 3.5.0 | 8.6.66 |
| `parse-server` | npm | From 9.0.0 | 9.7.0-alpha.10 |
| `parse-server` | npm | From 9.0.0 | 9.7.0-alpha.10 |
| `parse` | Bitnami | All versions | 8.6.66, 9.7.0 |

Products: Parseplatform Parse-Server.

## How do I fix CVE-2026-34373?

Upgrade parse-server to a fixed version for your release line: 8.6.66 or 9.7.0-alpha.10.

## Is CVE-2026-34373 being exploited?

There is no known exploitation of CVE-2026-34373 in the wild and no public exploit code.

## Other vulnerabilities in Parseplatform Parse-Server

- [CVE-2026-30966](https://insights.sbomify.com/CVE-2026-30966/): Parse Server role escalation and CLP bypass via direct `_Join` table write (critical 10.0)
- [CVE-2024-27298](https://insights.sbomify.com/CVE-2024-27298/): Parse Server literalizeRegexPart SQL Injection (critical 10.0)
- [CVE-2022-24760](https://insights.sbomify.com/CVE-2022-24760/): Command Injection in Parse server (critical 10.0)
- [CVE-2026-30965](https://insights.sbomify.com/CVE-2026-30965/): Parse Server session token exfiltration via `redirectClassNameForKey` query parameter (critical 9.9)
- [CVE-2023-36475](https://insights.sbomify.com/CVE-2023-36475/): Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34373 and fix it if it is affected.

What it is: CVE-2026-34373 is a medium-severity vulnerability in Parseplatform Parse-Server, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-34373 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server (npm): affected from 3.5.0; fixed in 8.6.66
- parse-server (npm): affected from 3.5.0; fixed in 8.6.66
- parse-server (npm): affected from 9.0.0; fixed in 9.7.0-alpha.10
- parse-server (npm): affected from 9.0.0; fixed in 9.7.0-alpha.10
- parse (Bitnami): affected all versions; fixed in 8.6.66, 9.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34373/ (Markdown: https://insights.sbomify.com/CVE-2026-34373/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34373
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34373
- OSV: https://osv.dev/vulnerability/CVE-2026-34373

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34373/
Summaries are generated and may contain mistakes; the official description above is the record.
