# CVE-2026-34379: OpenEXR has a misaligned write in LossyDctDecoder_execute leading to undefined behavior (DWA/DWAB decompression)

> A misaligned memory write in OpenEXR's DWA decoder can cause crashes or potential code execution when processing malicious EXR files.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Apr 2026
- **Updated:** 15 Jul 2026
- **Also known as:** BELL-CVE-2026-34379, DEBIAN-CVE-2026-34379, GHSA-w88v-vqhq-5p24, JLSEC-2026-143, ROOT-OS-DEBIAN-11-CVE-2026-34379, ROOT-OS-DEBIAN-12-CVE-2026-34379, ROOT-OS-DEBIAN-13-CVE-2026-34379, UBUNTU-CVE-2026-34379

## What is CVE-2026-34379?

CVE-2026-34379 is a high-severity memory corruption vulnerability in Openexr Openexr, published on 6 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. From 3.2.0 to before 3.2.7, 3.3.9, and 3.4.9, a misaligned memory write vulnerability exists in LossyDctDecoder_execute() in src/lib/OpenEXRCore/internal_dwa_decoder.h:749. When decoding a DWA or DWAB-compressed EXR file containing a FLOAT-type channel, the decoder performs an in-place HALF→FLOAT conversion by casting an unaligned uint8_t * row pointer to float * and writing through it. Because the row buffer may not be 4-byte aligned, this constitutes undefined behavior under the C standard and crashes immediately on architectures that enforce alignment (ARM, RISC-V, etc.). On x86 it is silently tolerated at runtime but remains exploitable via compiler optimizations that assume aligned access. This vulnerability is fixed in 3.2.7, 3.3.9, and 3.4.9.

Weakness: CWE-843 (Access of Resource Using Incompatible Type), CWE-475 (Undefined Behavior for Input to API), CWE-787 (Out-of-bounds Write), CWE-704 (Incorrect Type Conversion or Cast)

## Which versions are affected by CVE-2026-34379?

It affects 1 product.


Products: Openexr Openexr.

## How do I fix CVE-2026-34379?

Upgrade to a fixed version.

## Is CVE-2026-34379 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34379 exists.

## Other vulnerabilities in Openexr Openexr

- [CVE-2023-5841](https://insights.sbomify.com/CVE-2023-5841/): OpenEXR Heap Overflow in Scanline Deep Data Parsing (critical 9.1)
- [CVE-2026-41142](https://insights.sbomify.com/CVE-2026-41142/): OpenEXR is Vulnerable to Integer overflow in ImageChannel::resize leads to heap OOB write via OpenEXRUtil public API (high 8.8)
- [CVE-2026-42216](https://insights.sbomify.com/CVE-2026-42216/): OpenEXR: Out-of-bounds read in `IDManifest::init()` during prefix expansion (high 8.8)
- [CVE-2017-9111](https://insights.sbomify.com/CVE-2017-9111/): OpenEXR invalid write (high 8.8)
- [CVE-2017-9113](https://insights.sbomify.com/CVE-2017-9113/): Memory corruption in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34379 and fix it if it is affected.

What it is: CVE-2026-34379 is a high-severity memory corruption vulnerability in Openexr Openexr, published on 6 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34379 exists.

Affected product: Openexr Openexr. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34379/ (Markdown: https://insights.sbomify.com/CVE-2026-34379/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34379
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34379
- OSV: https://osv.dev/vulnerability/CVE-2026-34379

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34379/
Summaries are generated and may contain mistakes; the official description above is the record.
