# CVE-2026-34380: Integer overflow in openexr

> A signed integer overflow in OpenEXR's PXR24 decompression can bypass bounds checks, leading to out-of-bounds writes and potential code execution.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Apr 2026
- **Updated:** 12 May 2026
- **Also known as:** BELL-CVE-2026-34380, DEBIAN-CVE-2026-34380, GHSA-q3v8-hw4m-59w5, JLSEC-2026-144, ROOT-OS-DEBIAN-11-CVE-2026-34380, ROOT-OS-DEBIAN-12-CVE-2026-34380, ROOT-OS-DEBIAN-13-CVE-2026-34380, UBUNTU-CVE-2026-34380

## What is CVE-2026-34380?

CVE-2026-34380 is a medium-severity vulnerability in Openexr Openexr, published on 6 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. From 3.2.0 to before 3.2.7, 3.3.9, and 3.4.9, a signed integer overflow exists in undo_pxr24_impl() in src/lib/OpenEXRCore/internal_pxr24.c at line 377. The expression (uint64_t)(w * 3) computes w * 3 as a signed 32-bit integer before casting to uint64_t. When w is large, this multiplication constitutes undefined behavior under the C standard. On tested builds (clang/gcc without sanitizers), two's-complement wraparound commonly occurs, and for specific values of w the wrapped result is a small positive integer, which may allow the subsequent bounds check to pass incorrectly. If the check is bypassed, the decoding loop proceeds to write pixel data through dout, potentially extending far beyond the allocated output buffer. This vulnerability is fixed in 3.2.7, 3.3.9, and 3.4.9.

Weakness: CWE-787 (Out-of-bounds Write), CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2026-34380?

It affects 1 product.


Products: Openexr Openexr.

## How do I fix CVE-2026-34380?

Upgrade to a fixed version.

## Is CVE-2026-34380 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34380 exists.

## Other vulnerabilities in Openexr Openexr

- [CVE-2023-5841](https://insights.sbomify.com/CVE-2023-5841/): OpenEXR Heap Overflow in Scanline Deep Data Parsing (critical 9.1)
- [CVE-2026-41142](https://insights.sbomify.com/CVE-2026-41142/): OpenEXR is Vulnerable to Integer overflow in ImageChannel::resize leads to heap OOB write via OpenEXRUtil public API (high 8.8)
- [CVE-2026-42216](https://insights.sbomify.com/CVE-2026-42216/): OpenEXR: Out-of-bounds read in `IDManifest::init()` during prefix expansion (high 8.8)
- [CVE-2017-9111](https://insights.sbomify.com/CVE-2017-9111/): OpenEXR invalid write (high 8.8)
- [CVE-2017-9113](https://insights.sbomify.com/CVE-2017-9113/): Memory corruption in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34380 and fix it if it is affected.

What it is: CVE-2026-34380 is a medium-severity vulnerability in Openexr Openexr, published on 6 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34380 exists.

Affected product: Openexr Openexr. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34380/ (Markdown: https://insights.sbomify.com/CVE-2026-34380/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34380
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34380
- OSV: https://osv.dev/vulnerability/CVE-2026-34380

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34380/
Summaries are generated and may contain mistakes; the official description above is the record.
