CVE-2026-34390 MantisBT: Privilege Escalation from Manager to Administrator

Medium 5.1 Published Updated

MantisBT allows managers to escalate to project-level administrators via forged access levels, requiring an upgrade to fix.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-34390?

CVE-2026-34390 is a medium-severity vulnerability in mantisbt, published on 19 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Mantis Bug Tracker (MantisBT) is an open source issue tracker. Versions 2.28.1 and prior have a Privilege Escalation vulnerability where insufficient access control checks in ProjectUsersAddCommand (manage_proj_user_add.php) allow users having manage_project_threshold access level (manager by default) to grant project-level administrator access to any user (including themselves) in any Project they have manager rights in. The normal project-user add form restricts the selectable access levels to the actor's own project role or below. However, the backend handler still accepts a forged higher access_level value and writes it. The consequences of the privilege escalation are slight, as having administrator access at Project level is effectively not very different from being manager, and it does not actually give administrator privileges on the whole MantisBT instance. In particular, it does not let the upgraded user delete the Project or grant them any access to global administrative functions such as managing Users, Projects, Plugins, Custom Fields, etc. This issue has been fixed in version 2.28.2.

Weakness: CWE-284

Which versions are affected by CVE-2026-34390?

2 open source packages ship an affected version, including mantisbt/mantisbt.

PackageAffectedFixed in
mantisbt/mantisbt PackagistAll versions2.28.2
mantisbt/mantisbt PackagistAll versions2.28.2

How do I fix CVE-2026-34390?

Upgrade mantisbt/mantisbt to 2.28.2 or later.

Is CVE-2026-34390 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34390 exists.

Sources

Also known as GHSA-frf7-jhp9-jxm6.

Is CVE-2026-34390 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free