# CVE-2026-34390: MantisBT: Privilege Escalation from Manager to Administrator

> MantisBT allows managers to escalate to project-level administrators via forged access levels, requiring an upgrade to fix.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 May 2026
- **Updated:** 20 May 2026
- **Also known as:** GHSA-frf7-jhp9-jxm6

## What is CVE-2026-34390?

CVE-2026-34390 is a medium-severity vulnerability in mantisbt, published on 19 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Mantis Bug Tracker (MantisBT) is an open source issue tracker. Versions 2.28.1 and prior have a Privilege Escalation vulnerability where insufficient access control checks in ProjectUsersAddCommand (manage_proj_user_add.php) allow users having manage_project_threshold access level (manager by default) to grant project-level administrator access to any user (including themselves) in any Project they have manager rights in. The normal project-user add form restricts the selectable access levels to the actor's own project role or below. However, the backend handler still accepts a forged higher access_level value and writes it. The consequences of the privilege escalation are slight, as having administrator access at Project level is effectively not very different from being manager, and it does not actually give administrator privileges on the whole MantisBT instance. In particular, it does not let the upgraded user delete the Project or grant them any access to global administrative functions such as managing Users, Projects, Plugins, Custom Fields, etc. This issue has been fixed in version 2.28.2.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-34390?

2 open source packages ship an affected version, including mantisbt/mantisbt.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mantisbt/mantisbt` | Packagist | All versions | 2.28.2 |
| `mantisbt/mantisbt` | Packagist | All versions | 2.28.2 |

## How do I fix CVE-2026-34390?

Upgrade mantisbt/mantisbt to 2.28.2 or later.

## Is CVE-2026-34390 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34390 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34390 and fix it if it is affected.

What it is: CVE-2026-34390 is a medium-severity vulnerability in mantisbt, published on 19 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34390 exists.

Affected packages and fixed versions:
- mantisbt/mantisbt (Packagist): affected all versions; fixed in 2.28.2
- mantisbt/mantisbt (Packagist): affected all versions; fixed in 2.28.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34390/ (Markdown: https://insights.sbomify.com/CVE-2026-34390/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34390
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34390
- OSV: https://osv.dev/vulnerability/CVE-2026-34390

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34390/
Summaries are generated and may contain mistakes; the official description above is the record.
