{"answers":{"affected":"3 open source packages ship an affected version, including weblate and Weblate. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-34393 in the wild and no public exploit code.","fix":"Upgrade weblate to 5.17 or later.","what":"CVE-2026-34393 is a high-severity vulnerability in WeblateOrg weblate, published on 15 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-34393 and fix it if it is affected.\n\nWhat it is: CVE-2026-34393 is a high-severity vulnerability in WeblateOrg weblate, published on 15 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-34393 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- weblate (PyPI): affected all versions; fixed in 5.17\n- weblate (PyPI): affected all versions; fixed in 5.17\n- Weblate (PyPI): affected all versions; fixed in 5.17\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-34393/ (Markdown: https://insights.sbomify.com/CVE-2026-34393/index.md)","id":"CVE-2026-34393","markdown":"https://insights.sbomify.com/CVE-2026-34393/index.md","name":"CVE-2026-34393","record":{"aliases":["GHSA-3382-gw9x-477v","PYSEC-2026-155"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Weblate localization tool","requires_auth":"low_privilege","summary":"Attackers can escalate privileges via the user patching API endpoint due to insufficient edit scope limitations in Weblate.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"weblate","vendor":"weblate"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"Weblate is a web based localization tool. In versions prior to 5.17, the user patching API endpoint didn't properly limit the scope of edits. This issue has been fixed in version 5.17.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Weblate: Privilege escalation in the user API endpoint","id":"CVE-2026-34393","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"privilege_escalation","year":"2026"},"n_packages":3,"n_references":2,"next":{"headline":"AVideo: CSRF on Admin Plugin Configuration Enables Payment Credential Hijacking","id":"CVE-2026-34394"},"packages":[{"ecosystem":"PyPI","fixed":["5.17"],"introduced":["0"],"last_affected":[],"package":"Weblate","purl":null,"source":"GHSA-3382-gw9x-477v"},{"ecosystem":"PyPI","fixed":["5.17"],"introduced":["0"],"last_affected":[],"package":"weblate","purl":"pkg:pypi/weblate","source":"GHSA-3382-gw9x-477v"},{"ecosystem":"PyPI","fixed":["5.17"],"introduced":["0"],"last_affected":[],"package":"weblate","purl":"pkg:pypi/weblate","source":"PYSEC-2026-155"}],"prev":{"headline":"LORIS has a path traversal in static router","id":"CVE-2026-34392"},"products":["weblate"],"published":"2026-04-15","related":[{"cvss_score":9.1,"headline":"Weblate has git config file overwrite vulnerability that leads to remote code execution","id":"CVE-2025-68398","kev_date_added":null,"published":"2025-12-18"},{"cvss_score":8.1,"headline":"Weblate: Remote code execution during backup restoration","id":"CVE-2026-33435","kev_date_added":null,"published":"2026-04-15"},{"cvss_score":7.7,"headline":"Weblate: Arbitrary File Read via Symlink","id":"CVE-2026-34242","kev_date_added":null,"published":"2026-04-15"},{"cvss_score":7.7,"headline":"Weblate has an arbitrary file read via symbolic links","id":"CVE-2025-68279","kev_date_added":null,"published":"2025-12-18"},{"cvss_score":7.2,"headline":"Remote Code Execution (RCE)","id":"CVE-2022-23915","kev_date_added":null,"published":"2022-03-04"},{"cvss_score":6.8,"headline":"Weblate: JavaScript localization CDN add-on allows arbitrary local file read outside the repository","id":"CVE-2026-33220","kev_date_added":null,"published":"2026-04-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-15","vendors":["WeblateOrg"]},"summary":"Attackers can escalate privileges via the user patching API endpoint due to insufficient edit scope limitations in Weblate.","url":"https://insights.sbomify.com/CVE-2026-34393/"}