{"answers":{"affected":"3 open source packages ship an affected version, including alerta-server. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-34400 in the wild and no public exploit code.","fix":"Upgrade alerta-server to 9.1.0 or later.","what":"CVE-2026-34400 is a medium-severity SQL injection vulnerability in alerta, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-34400 and fix it if it is affected.\n\nWhat it is: CVE-2026-34400 is a medium-severity SQL injection vulnerability in alerta, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-34400 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- alerta-server (PyPI): affected all versions; fixed in 9.1.0\n- alerta-server (PyPI): affected all versions; fixed in 9.1.0\n- alerta-server (PyPI): affected all versions; fixed in 9.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-34400/ (Markdown: https://insights.sbomify.com/CVE-2026-34400/index.md)","id":"CVE-2026-34400","markdown":"https://insights.sbomify.com/CVE-2026-34400/index.md","name":"CVE-2026-34400","record":{"aliases":["GHSA-8prr-286p-4w7j","PYSEC-2026-2341"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Alerta monitoring tool","requires_auth":"none","summary":"Attackers can execute arbitrary SQL commands via the query string API, potentially reading or modifying database contents.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"alerta","vendor":"alerta_project"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"Alerta is a monitoring tool. Prior to version 9.1.0, the Query string search API (q=) was vulnerable to SQL injection via the Postgres query parser, which built WHERE clauses by interpolating user-supplied search terms directly into SQL strings via f-strings. This issue has been patched in version 9.1.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"alerta-server has potential SQL Injection vulnerability in Query String Syntax (q=) API","id":"CVE-2026-34400","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"sql_injection","year":"2026"},"n_packages":3,"n_references":6,"next":{"headline":"XML Notepad: XML External Entity (XXE) Injection via Unsafe XmlTextReader in XML Diff and Schema Loading","id":"CVE-2026-34401"},"packages":[{"ecosystem":"PyPI","fixed":["9.1.0"],"introduced":["0"],"last_affected":[],"package":"alerta-server","purl":null,"source":"GHSA-8prr-286p-4w7j"},{"ecosystem":"PyPI","fixed":["9.1.0"],"introduced":["0"],"last_affected":[],"package":"alerta-server","purl":"pkg:pypi/alerta-server","source":"GHSA-8prr-286p-4w7j"},{"ecosystem":"PyPI","fixed":["9.1.0"],"introduced":["0"],"last_affected":[],"package":"alerta-server","purl":"pkg:pypi/alerta-server","source":"PYSEC-2026-2341"}],"prev":{"headline":"FreeCAD: Arbitrary Code Execution via eval() on untrusted SVG template scale field in BIM TechDraw Page","id":"CVE-2026-34399"},"products":["alerta"],"published":"2026-03-31","related":[{"cvss_score":9.1,"headline":"LDAP authentication bypass in Alerta","id":"CVE-2020-26214","kev_date_added":null,"published":"2020-11-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-03","vendors":["alerta"]},"summary":"Attackers can execute arbitrary SQL commands via the query string API, potentially reading or modifying database contents.","url":"https://insights.sbomify.com/CVE-2026-34400/"}