# CVE-2026-34403: Nginx-UI vulnerable to Cross-Site WebSocket Hijacking (CSWSH) via missing origin validation on all WebSocket endpoints

> Attackers can hijack authenticated WebSocket sessions via CSRF, potentially leading to account takeover or code execution on the Nginx UI.

- **Severity:** Medium 5.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Apr 2026
- **Updated:** 21 Apr 2026
- **Also known as:** GHSA-78mf-482w-62qj, GO-2026-5210

## What is CVE-2026-34403?

CVE-2026-34403 is a medium-severity vulnerability in 0xJacky nginx-ui, published on 20 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Nginx UI is a web user interface for the Nginx web server. Prior to version 2.3.5, all WebSocket endpoints in nginx-ui use a gorilla/websocket Upgrader with CheckOrigin unconditionally returning true, allowing Cross-Site WebSocket Hijacking (CSWSH). Combined with the fact that authentication tokens are stored in browser cookies (set via JavaScript without HttpOnly or explicit SameSite attributes), a malicious webpage can establish authenticated WebSocket connections to the nginx-ui instance when a logged-in administrator visits the attacker-controlled page. Version 2.3.5 patches the issue.

Weakness: CWE-1385 (Missing Origin Validation in WebSockets)

## Which versions are affected by CVE-2026-34403?

3 open source packages ship an affected version, including github.com/0xJacky/Nginx-UI. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/0xJacky/Nginx-UI` | Go | All versions | 1.9.10-0.20260316053337-1a9cd29a3082 |
| `github.com/0xJacky/Nginx-UI` | Go | All versions | 1.9.10-0.20260316053337-1a9cd29a3082 |
| `github.com/0xJacky/Nginx-UI` | Go | All versions | 1.9.10-0.20260316053337-1a9cd29a3082 |

Products: Nginxui Nginx Ui.

## How do I fix CVE-2026-34403?

Upgrade github.com/0xJacky/Nginx-UI to 1.9.10-0.20260316053337-1a9cd29a3082 or later.

## Is CVE-2026-34403 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34403 exists.

## Other vulnerabilities in 0xJacky nginx-ui

- [CVE-2026-33032](https://insights.sbomify.com/CVE-2026-33032/): Nginx UI: Unauthenticated MCP Endpoint Allows Remote Nginx Takeover (critical 9.8)
- [CVE-2026-27944](https://insights.sbomify.com/CVE-2026-27944/): Nginx UI: Unauthenticated Backup Download with Encryption Key Disclosure (critical 9.8)
- [CVE-2024-23827](https://insights.sbomify.com/CVE-2024-23827/): Nginx-UI arbitrary file write through the Import Certificate feature (critical 9.8)
- [CVE-2026-107806](https://insights.sbomify.com/CVE-2026-107806/): Nginx UI: Authenticated Remote Code Execution via Backup Restore App Config Overwrite (critical 9.4)
- [CVE-2026-33026](https://insights.sbomify.com/CVE-2026-33026/): nginx-ui Backup Restore Allows Tampering with Encrypted Backups (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34403 and fix it if it is affected.

What it is: CVE-2026-34403 is a medium-severity vulnerability in 0xJacky nginx-ui, published on 20 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34403 exists.

Affected packages and fixed versions:
- github.com/0xJacky/Nginx-UI (Go): affected all versions; fixed in 1.9.10-0.20260316053337-1a9cd29a3082
- github.com/0xJacky/Nginx-UI (Go): affected all versions; fixed in 1.9.10-0.20260316053337-1a9cd29a3082
- github.com/0xJacky/Nginx-UI (Go): affected all versions; fixed in 1.9.10-0.20260316053337-1a9cd29a3082

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34403/ (Markdown: https://insights.sbomify.com/CVE-2026-34403/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34403
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34403
- OSV: https://osv.dev/vulnerability/CVE-2026-34403

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34403/
Summaries are generated and may contain mistakes; the official description above is the record.
