# CVE-2026-34404: Nuxt OG Image vulnerable to DoS via image generation

> Attackers can cause denial of service in Nuxt OG Image by requesting images with unrestricted dimensions, requiring an upgrade to the module.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Mar 2026
- **Updated:** 1 Apr 2026
- **Also known as:** GHSA-c7xp-q6q8-hg76

## What is CVE-2026-34404?

CVE-2026-34404 is a medium-severity denial of service vulnerability in nuxt-modules og-image, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Nuxt OG Image generates OG Images with Vue templates in Nuxt. Prior to version 6.2.5, the image‑generation component by the URI: /_og/d/ (and, in older versions, /og-image/) contains a Denial of Service (DoS) vulnerability. The issue arises because there is no restriction on the width and height parameters of the generated image. The vulnerability was reproduced using the standard configuration and the default templates. This issue has been patched in version 6.2.5.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-34404?

2 open source packages ship an affected version, including nuxt-og-image. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nuxt-og-image` | npm | All versions | 6.2.5 |
| `nuxt-og-image` | npm | All versions | 6.2.5 |

Products: Nuxt Og Image.

## How do I fix CVE-2026-34404?

Upgrade nuxt-og-image to 6.2.5 or later.

## Is CVE-2026-34404 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34404 exists.

## Other vulnerabilities in nuxt-modules og-image

- [CVE-2026-34405](https://insights.sbomify.com/CVE-2026-34405/): Nuxt OG Image vulnerable to reflected XSS via query parameter injection into HTML attributes (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34404 and fix it if it is affected.

What it is: CVE-2026-34404 is a medium-severity denial of service vulnerability in nuxt-modules og-image, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34404 exists.

Affected packages and fixed versions:
- nuxt-og-image (npm): affected all versions; fixed in 6.2.5
- nuxt-og-image (npm): affected all versions; fixed in 6.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34404/ (Markdown: https://insights.sbomify.com/CVE-2026-34404/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34404
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34404
- OSV: https://osv.dev/vulnerability/CVE-2026-34404

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34404/
Summaries are generated and may contain mistakes; the official description above is the record.
