# CVE-2026-34405: Nuxt OG Image vulnerable to reflected XSS via query parameter injection into HTML attributes

> Attackers can inject arbitrary HTML attributes via query parameters in Nuxt OG Image, leading to reflected XSS and potential code execution.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Mar 2026
- **Updated:** 1 Apr 2026
- **Also known as:** GHSA-mg36-wvcr-m75h

## What is CVE-2026-34405?

CVE-2026-34405 is a medium-severity cross-site scripting vulnerability in nuxt-modules og-image, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Nuxt OG Image generates OG Images with Vue templates in Nuxt. Prior to version 6.2.5, the image‑generation component by the URI: /_og/d/ (and, in older versions, /og-image/) contains a vulnerability that allows injection of arbitrary attributes into the HTML page body. This issue has been patched in version 6.2.5.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-34405?

2 open source packages ship an affected version, including nuxt-og-image. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nuxt-og-image` | npm | All versions | 6.2.5 |
| `nuxt-og-image` | npm | All versions | 6.2.5 |

Products: Nuxt Og Image.

## How do I fix CVE-2026-34405?

Upgrade nuxt-og-image to 6.2.5 or later.

## Is CVE-2026-34405 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34405 exists.

## Other vulnerabilities in nuxt-modules og-image

- [CVE-2026-34404](https://insights.sbomify.com/CVE-2026-34404/): Nuxt OG Image vulnerable to DoS via image generation (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34405 and fix it if it is affected.

What it is: CVE-2026-34405 is a medium-severity cross-site scripting vulnerability in nuxt-modules og-image, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34405 exists.

Affected packages and fixed versions:
- nuxt-og-image (npm): affected all versions; fixed in 6.2.5
- nuxt-og-image (npm): affected all versions; fixed in 6.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34405/ (Markdown: https://insights.sbomify.com/CVE-2026-34405/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34405
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34405
- OSV: https://osv.dev/vulnerability/CVE-2026-34405

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34405/
Summaries are generated and may contain mistakes; the official description above is the record.
