{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34406 exists.","fix":"No fix has been published for CVE-2026-34406 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-34406 is a critical vulnerability in APTRS, published on 31 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-34406 and fix it if it is affected.\n\nWhat it is: CVE-2026-34406 is a critical vulnerability in APTRS, published on 31 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34406 exists.\n\nAffected product: APTRS. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-34406/ (Markdown: https://insights.sbomify.com/CVE-2026-34406/index.md)","id":"CVE-2026-34406","markdown":"https://insights.sbomify.com/CVE-2026-34406/index.md","name":"CVE-2026-34406","record":{"aliases":["GHSA-gv25-wp4h-9c35"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Penetration testing tool","requires_auth":"low_privilege","summary":"Attackers can escalate privileges to superuser by modifying the is_superuser field in user edit requests, granting unrestricted access to the APTRS reporting system.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"aptrs","vendor":"aptrs"}],"cvss":{"score":9.4,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-915","name":"Improperly Controlled Modification of Dynamically-Determined Object Attributes"}],"description":"APTRS (Automated Penetration Testing Reporting System) is a Python and Django-based automated reporting tool designed for penetration testers and security organizations. Prior to version 2.0.1, the edit_user endpoint (POST /api/auth/edituser/\u003cpk\u003e) allows Any user who can reach that endpoint and submit crafted permission to escalate their own account (or any other account) to superuser by including \"is_superuser\": true in the request body. The root cause is that CustomUserSerializer explicitly includes is_superuser in its fields list but omits it from read_only_fields, making it a writable field. The edit_user view performs no additional validation to prevent non-superusers from modifying this field. Once is_superuser is set to true, gaining unrestricted access to all application functionality without requiring re-authentication. This issue has been patched in version 2.0.1.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"APTRS: Privilege Escalation via Mass Assignment of is_superuser in User Edit Endpoint","id":"CVE-2026-34406","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"privilege_escalation","year":"2026"},"n_packages":0,"n_references":3,"next":{"headline":"Auth bypass in n/a","id":"CVE-2026-34408"},"packages":[],"prev":{"headline":"Nuxt OG Image vulnerable to reflected XSS via query parameter injection into HTML attributes","id":"CVE-2026-34405"},"products":["APTRS"],"published":"2026-03-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-03","vendors":["APTRS"]},"summary":"Attackers can escalate privileges to superuser by modifying the is_superuser field in user edit requests, granting unrestricted access to the APTRS reporting system.","url":"https://insights.sbomify.com/CVE-2026-34406/"}