# CVE-2026-34406: APTRS: Privilege Escalation via Mass Assignment of is_superuser in User Edit Endpoint

> Attackers can escalate privileges to superuser by modifying the is_superuser field in user edit requests, granting unrestricted access to the APTRS reporting system.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 31 Mar 2026
- **Updated:** 3 Apr 2026
- **Also known as:** GHSA-gv25-wp4h-9c35

## What is CVE-2026-34406?

CVE-2026-34406 is a critical vulnerability in APTRS, published on 31 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

APTRS (Automated Penetration Testing Reporting System) is a Python and Django-based automated reporting tool designed for penetration testers and security organizations. Prior to version 2.0.1, the edit_user endpoint (POST /api/auth/edituser/<pk>) allows Any user who can reach that endpoint and submit crafted permission to escalate their own account (or any other account) to superuser by including "is_superuser": true in the request body. The root cause is that CustomUserSerializer explicitly includes is_superuser in its fields list but omits it from read_only_fields, making it a writable field. The edit_user view performs no additional validation to prevent non-superusers from modifying this field. Once is_superuser is set to true, gaining unrestricted access to all application functionality without requiring re-authentication. This issue has been patched in version 2.0.1.

Weakness: CWE-915 (Improperly Controlled Modification of Dynamically-Determined Object Attributes)

## Which versions are affected by CVE-2026-34406?

It affects 1 product.


Products: Aptrs Aptrs.

## How do I fix CVE-2026-34406?

No fix has been published for CVE-2026-34406 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-34406 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34406 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34406 and fix it if it is affected.

What it is: CVE-2026-34406 is a critical vulnerability in APTRS, published on 31 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34406 exists.

Affected product: APTRS. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34406/ (Markdown: https://insights.sbomify.com/CVE-2026-34406/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34406
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34406
- OSV: https://osv.dev/vulnerability/CVE-2026-34406

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34406/
Summaries are generated and may contain mistakes; the official description above is the record.
