# CVE-2026-34454: OAuth2 Proxy: Session cookie not cleared when rendering sign-in page

> Attackers on shared devices can hijack sessions because the proxy fails to clear cookies during sign-in page rendering, requiring specific logout flow configurations.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Apr 2026
- **Updated:** 15 Apr 2026
- **Also known as:** BIT-oauth2-proxy-2026-34454, GHSA-f24x-5g9q-753f, GO-2026-5341, MINI-m8xg-wgh8-86m2, MINI-wcv9-4mcj-w659

## What is CVE-2026-34454?

CVE-2026-34454 is a low-severity authentication bypass vulnerability in oauth2-proxy, published on 14 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

OAuth2 Proxy is a reverse proxy that provides authentication using OAuth2 providers. A regression introduced in 7.11.0 prevents OAuth2 Proxy from clearing the session cookie when rendering the sign-in page. In deployments that rely on the sign-in page as part of their logout flow, a user may be shown the sign-in page while the existing session cookie remains valid, meaning the browser session is not actually logged out. On shared workstations or devices, a subsequent user could continue to use the previous user's authenticated session. Deployments that use a dedicated logout/sign-out endpoint to terminate sessions are not affected. This issue is fixed in 7.15.2

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration), CWE-384 (Session Fixation)

## Which versions are affected by CVE-2026-34454?

5 open source packages ship an affected version, including github.com/oauth2-proxy/oauth2-proxy/v7, oauth2-proxy and github.com/oauth2-proxy/oauth2-proxy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/oauth2-proxy/oauth2-proxy/v7` | Go | From 7.11.0 | 7.15.2 |
| `github.com/oauth2-proxy/oauth2-proxy/v7` | Go | From 7.11.0 | 7.15.2 |
| `github.com/oauth2-proxy/oauth2-proxy/v7` | Go | From 7.11.0 | 7.15.2 |
| `oauth2-proxy` | Bitnami | From 7.11.0 | 7.15.2 |
| `github.com/oauth2-proxy/oauth2-proxy` | Go | All versions | None |

Products: Oauth2 Proxy Project Oauth2 Proxy.

## How do I fix CVE-2026-34454?

Upgrade github.com/oauth2-proxy/oauth2-proxy/v7 to 7.15.2 or later.

## Is CVE-2026-34454 being exploited?

There is no known exploitation of CVE-2026-34454 in the wild and no public exploit code.

## Other vulnerabilities in oauth2-proxy

- [CVE-2026-40575](https://insights.sbomify.com/CVE-2026-40575/): OAuth2 Proxy has an Authentication Bypass via X-Forwarded-Uri Header Spoofing (critical 9.1)
- [CVE-2026-34457](https://insights.sbomify.com/CVE-2026-34457/): OAuth2 Proxy: Health Check User-Agent Matching Bypasses Authentication in auth_request Mode (critical 9.1)
- [CVE-2025-54576](https://insights.sbomify.com/CVE-2025-54576/): OAuth2-Proxy has authentication bypass in oauth2-proxy skip_auth_routes due to Query Parameter inclusion (critical 9.1)
- [CVE-2017-1000069](https://insights.sbomify.com/CVE-2017-1000069/): Cross-site Request Forgery (CSRF) (high 8.8)
- [CVE-2026-41059](https://insights.sbomify.com/CVE-2026-41059/): OAuth2 Proxy has an Authentication Bypass via Fragment Confusion in skip_auth_routes and skip_auth_regex (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34454 and fix it if it is affected.

What it is: CVE-2026-34454 is a low-severity authentication bypass vulnerability in oauth2-proxy, published on 14 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-34454 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/oauth2-proxy/oauth2-proxy/v7 (Go): affected from 7.11.0; fixed in 7.15.2
- github.com/oauth2-proxy/oauth2-proxy/v7 (Go): affected from 7.11.0; fixed in 7.15.2
- github.com/oauth2-proxy/oauth2-proxy/v7 (Go): affected from 7.11.0; fixed in 7.15.2
- oauth2-proxy (Bitnami): affected from 7.11.0; fixed in 7.15.2
- github.com/oauth2-proxy/oauth2-proxy (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34454/ (Markdown: https://insights.sbomify.com/CVE-2026-34454/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34454
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34454
- OSV: https://osv.dev/vulnerability/CVE-2026-34454

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34454/
Summaries are generated and may contain mistakes; the official description above is the record.
