# CVE-2026-34455: Hi.Events: SQL Injection via Unvalidated sort_by Query Parameter in Multiple Repository Classes

> Attackers can execute arbitrary SQL commands via the sort_by parameter in Hi.Events, potentially reading or modifying database contents.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 1 Apr 2026
- **Updated:** 2 Apr 2026
- **Also known as:** GHSA-2qcp-24fh-fx6p

## What is CVE-2026-34455?

CVE-2026-34455 is a high-severity SQL injection vulnerability in HiEventsDev Hi.Events, published on 1 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Hi.Events is an open-source event management and ticket selling platform. From version 0.8.0-beta.1 to before version 1.7.1-beta, multiple repository classes pass the user-supplied sort_by query parameter directly to Eloquent's orderBy() without validation, enabling SQL injection. The application uses PostgreSQL which supports stacked queries. This issue has been patched in version 1.7.1-beta.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-34455?

It affects 1 product.


Products: Hi.events Hi.events.

## How do I fix CVE-2026-34455?

No fix has been published for CVE-2026-34455 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-34455 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34455 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34455 and fix it if it is affected.

What it is: CVE-2026-34455 is a high-severity SQL injection vulnerability in HiEventsDev Hi.Events, published on 1 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34455 exists.

Affected product: HiEventsDev Hi.Events. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34455/ (Markdown: https://insights.sbomify.com/CVE-2026-34455/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34455
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34455
- OSV: https://osv.dev/vulnerability/CVE-2026-34455

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34455/
Summaries are generated and may contain mistakes; the official description above is the record.
