# CVE-2026-34463: MantisBT has Stored HTML Injection/XSS via Clone Issue Form

> Attackers with manager access can inject HTML into project names, leading to stored XSS when users clone issues from other projects.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 May 2026
- **Updated:** 20 May 2026
- **Also known as:** GHSA-fvjf-68wh-rwp2

## What is CVE-2026-34463?

CVE-2026-34463 is a high-severity cross-site scripting vulnerability in mantisbt, published on 19 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Mantis Bug Tracker (MantisBT) is an open source issue tracker. Versions 2.28.1 and prior contain a Stored XSS vulnerability. When cloning an issue originating from a Project other than the current one, the clone form (bug_report_page.php) prepends the source Project name before the category selector without proper escaping, allowing an attacker able to to inject HTML if they can set the Project's name (which typically requires manager or administrator access level). This issue has been resolved in version 2.28.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-34463?

2 open source packages ship an affected version, including mantisbt/mantisbt.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mantisbt/mantisbt` | Packagist | All versions | 2.28.2 |
| `mantisbt/mantisbt` | Packagist | All versions | 2.28.2 |

## How do I fix CVE-2026-34463?

Upgrade mantisbt/mantisbt to 2.28.2 or later.

## Is CVE-2026-34463 being exploited?

There is no known exploitation of CVE-2026-34463 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34463 and fix it if it is affected.

What it is: CVE-2026-34463 is a high-severity cross-site scripting vulnerability in mantisbt, published on 19 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-34463 in the wild and no public exploit code.

Affected packages and fixed versions:
- mantisbt/mantisbt (Packagist): affected all versions; fixed in 2.28.2
- mantisbt/mantisbt (Packagist): affected all versions; fixed in 2.28.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34463/ (Markdown: https://insights.sbomify.com/CVE-2026-34463/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34463
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34463
- OSV: https://osv.dev/vulnerability/CVE-2026-34463

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34463/
Summaries are generated and may contain mistakes; the official description above is the record.
