# CVE-2026-34476: Apache SkyWalking MCP: Server-Side Request Forgery via SW-URL Header in MCP Server

> An attacker can exploit a Server-Side Request Forgery vulnerability in Apache SkyWalking MCP via the SW-URL header to access internal resources.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Apr 2026
- **Updated:** 13 Apr 2026
- **Also known as:** GHSA-c4hg-6933-x62x, GO-2026-5310

## What is CVE-2026-34476?

CVE-2026-34476 is a high-severity server-side request forgery vulnerability in Apache SkyWalking MCP, published on 13 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Server-Side Request Forgery via SW-URL Header vulnerability in Apache SkyWalking MCP.

This issue affects Apache SkyWalking MCP: 0.1.0.

Users are recommended to upgrade to version 0.2.0, which fixes this issue.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-34476?

3 open source packages ship an affected version, including github.com/apache/skywalking-mcp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/apache/skywalking-mcp` | Go | All versions | 0.2.0 |
| `github.com/apache/skywalking-mcp` | Go | All versions | 0.2.0 |
| `github.com/apache/skywalking-mcp` | Go | All versions | 0.2.0 |

Products: Apache Skywalking Mcp.

## How do I fix CVE-2026-34476?

Upgrade github.com/apache/skywalking-mcp to 0.2.0 or later.

## Is CVE-2026-34476 being exploited?

There is no known exploitation of CVE-2026-34476 in the wild and no public exploit code.

## Other vulnerabilities in Apache SkyWalking MCP

- [CVE-2026-34884](https://insights.sbomify.com/CVE-2026-34884/): Apache SkyWalking MCP: SSRF via set_skywalking_url Tool and GraphQL Expression Injection in MCP Server (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34476 and fix it if it is affected.

What it is: CVE-2026-34476 is a high-severity server-side request forgery vulnerability in Apache SkyWalking MCP, published on 13 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-34476 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/apache/skywalking-mcp (Go): affected all versions; fixed in 0.2.0
- github.com/apache/skywalking-mcp (Go): affected all versions; fixed in 0.2.0
- github.com/apache/skywalking-mcp (Go): affected all versions; fixed in 0.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34476/ (Markdown: https://insights.sbomify.com/CVE-2026-34476/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34476
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34476
- OSV: https://osv.dev/vulnerability/CVE-2026-34476

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34476/
Summaries are generated and may contain mistakes; the official description above is the record.
