CVE-2026-34483 Apache Tomcat: Incomplete escaping of JSON access logs
Attackers can inject malicious scripts into JSON access logs, potentially leading to code execution or data theft if logs are viewed in a vulnerable interface.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-34483?
CVE-2026-34483 is a high-severity cross-site scripting vulnerability in Apache Tomcat, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper Encoding or Escaping of Output vulnerability in the JsonAccessLogValve component of Apache Tomcat.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.20, from 10.1.0-M1 through 10.1.53, from 9.0.40 through 9.0.116.
Users are recommended to upgrade to version 11.0.21, 10.1.54 or 9.0.117 , which fix the issue.
Weakness: CWE-116
Which versions are affected by CVE-2026-34483?
19 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.54 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.54 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.21 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.21 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.40 | 9.0.116 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.40 | 9.0.116 |
13 more packages
tomcat Bitnami | From 9.0.40 | 9.0.117, 10.1.54, 11.0.21 |
org.apache.tomcat:tomcat Maven | From 10.1.0-M1 | 10.1.54 |
org.apache.tomcat:tomcat Maven | From 10.1.0-M1 | 10.1.54 |
org.apache.tomcat:tomcat Maven | From 11.0.0-M1 | 11.0.21 |
org.apache.tomcat:tomcat Maven | From 11.0.0-M1 | 11.0.21 |
org.apache.tomcat:tomcat Maven | From 9.0.40 | 9.0.116 |
org.apache.tomcat:tomcat Maven | From 9.0.40 | 9.0.116 |
org.apache.tomcat:tomcat-catalina Maven | From 10.1.0-M1 | 10.1.54 |
org.apache.tomcat:tomcat-catalina Maven | From 10.1.0-M1 | 10.1.54 |
org.apache.tomcat:tomcat-catalina Maven | From 11.0.0-M1 | 11.0.21 |
org.apache.tomcat:tomcat-catalina Maven | From 11.0.0-M1 | 11.0.21 |
org.apache.tomcat:tomcat-catalina Maven | From 9.0.40 | 9.0.116 |
org.apache.tomcat:tomcat-catalina Maven | From 9.0.40 | 9.0.116 |
Products include Apache Tomcat.
How do I fix CVE-2026-34483?
Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.54, 11.0.21 or 9.0.116.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-34483 being exploited?
There is no known exploitation of CVE-2026-34483 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as BIT-tomcat-2026-34483, CLEANSTART-2026-NG48296, CLSA-2026-1776386117, CLSA-2026-1776818220, DEBIAN-CVE-2026-34483, GHSA-rv64-5gf8-9qq8 and 2 more.