CVE-2026-34487 Apache Tomcat: Cloud membership for clustering component exposed the Kubernetes bearer token
Apache Tomcat's clustering component logs Kubernetes bearer tokens, allowing attackers with log access to steal credentials and bypass security controls.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-34487?
CVE-2026-34487 is a high-severity vulnerability in Apache Tomcat, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Insertion of Sensitive Information into Log File vulnerability in the cloud membership for clustering component of Apache Tomcat exposed the Kubernetes bearer token.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.20, from 10.1.0-M1 through 10.1.53, from 9.0.13 through 9.0.116.
Users are recommended to upgrade to version 11.0.21, 10.1.54 or 9.0.117, which fix the issue.
Weakness: CWE-532
Which versions are affected by CVE-2026-34487?
19 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.54 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.54 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.21 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.21 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.13 | 9.0.117 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.13 | 9.0.117 |
13 more packages
tomcat Bitnami | From 9.0.13 | 9.0.117, 10.1.54, 11.0.21 |
org.apache.tomcat:tomcat Maven | From 10.1.0-M1 | 10.1.54 |
org.apache.tomcat:tomcat Maven | From 10.1.0-M1 | 10.1.54 |
org.apache.tomcat:tomcat Maven | From 11.0.0-M1 | 11.0.21 |
org.apache.tomcat:tomcat Maven | From 11.0.0-M1 | 11.0.21 |
org.apache.tomcat:tomcat Maven | From 9.0.13 | 9.0.117 |
org.apache.tomcat:tomcat Maven | From 9.0.13 | 9.0.117 |
org.apache.tomcat:tomcat-tribes Maven | From 10.1.0-M1 | 10.1.54 |
org.apache.tomcat:tomcat-tribes Maven | From 10.1.0-M1 | 10.1.54 |
org.apache.tomcat:tomcat-tribes Maven | From 11.0.0-M1 | 11.0.21 |
org.apache.tomcat:tomcat-tribes Maven | From 11.0.0-M1 | 11.0.21 |
org.apache.tomcat:tomcat-tribes Maven | From 9.0.13 | 9.0.117 |
org.apache.tomcat:tomcat-tribes Maven | From 9.0.13 | 9.0.117 |
Products include Apache Tomcat.
How do I fix CVE-2026-34487?
Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.54, 11.0.21 or 9.0.117.
Is CVE-2026-34487 being exploited?
There is no known exploitation of CVE-2026-34487 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as BIT-tomcat-2026-34487, CLEANSTART-2026-EJ54203, CLSA-2026-1776818219, CLSA-2026-1777250312, DEBIAN-CVE-2026-34487, GHSA-x4m4-345f-5h5g and 2 more.