# CVE-2026-3449: @tootallnate/once vulnerable to Incorrect Control Flow Scoping

> An attacker can cause indefinite hangs in applications using this library with AbortSignal, leading to stalled requests and degraded availability.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Mar 2026
- **Updated:** 4 May 2026
- **Also known as:** CLEANSTART-2026-JL75722, CLEANSTART-2026-RV70220, CLSA-2026-1792142145, ECHO-318f-4145-6b35, GHSA-vpq2-c234-7xj6, MINI-28xx-62cv-h8g7, MINI-2qgc-89pg-6j9p, MINI-2wq9-vxff-c5h5, MINI-35mx-8pfx-g3w2, MINI-3cqj-rhhg-5jxj, MINI-3frr-66jq-6p76, MINI-3q4j-5w37-q7px, MINI-4fhq-mrwp-fj26, MINI-4fpm-mhh4-c98j, MINI-5mf3-7j49-x2r9, MINI-62j7-qfrq-3xm8, MINI-6782-4f64-5q4c, MINI-797r-77q9-hxm4, MINI-86x7-q63p-mv3f, MINI-87rw-vc6j-97cp, MINI-8835-vhj8-776g, MINI-9ww6-hmxx-wv89, MINI-fcpj-x5vg-gxpm, MINI-fjpg-4jcx-4pwj, MINI-fq7h-x4px-cv49, MINI-g24m-5fpg-3397, MINI-jqm7-8v4j-h4gh, MINI-p6f6-82f6-q86g, MINI-q5vc-vw7w-3gqr, MINI-qjjg-j6jc-v74f, MINI-r555-wj8g-84p4, MINI-r9xw-mqw2-6c9g, MINI-vqcr-j45q-vpgp, MINI-w96f-xjmf-733j, MINI-wcx4-79w3-37xv, MINI-wpmj-jvx8-3fw6, MINI-wx23-rqhg-hw9w, ROOT-APP-NPM-CVE-2026-3449, openSUSE-SU-2026:10290-1, openSUSE-SU-2026:10429-1

## What is CVE-2026-3449?

CVE-2026-3449 is a medium-severity denial of service vulnerability in @tootallnate/once, published on 3 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Versions of the package @tootallnate/once before 3.0.1 are vulnerable to Incorrect Control Flow Scoping in promise resolving when AbortSignal option is used. The Promise remains in a permanently pending state after the signal is aborted, causing any await or .then() usage to hang indefinitely. This can cause a control-flow leak that can lead to stalled requests, blocked workers, or degraded application availability.

Weakness: CWE-705 (Incorrect Control Flow Scoping)

## Which versions are affected by CVE-2026-3449?

4 open source packages ship an affected version, including @tootallnate/once.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@tootallnate/once` | npm | All versions | 2.0.1 |
| `@tootallnate/once` | npm | All versions | 2.0.1 |
| `@tootallnate/once` | npm | From 3.0.0 | 3.0.1 |
| `@tootallnate/once` | npm | From 3.0.0 | 3.0.1 |
| `heroic-games-launcher` | openSUSE:Tumbleweed | All versions | 2.20.1-2.1 |
| `python-jupyterlab-templates` | openSUSE:Tumbleweed | All versions | 0.5.2-4.1 |

## How do I fix CVE-2026-3449?

Upgrade @tootallnate/once to a fixed version for your release line: 2.0.1 or 3.0.1.

## Is CVE-2026-3449 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-3449 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-3449 and fix it if it is affected.

What it is: CVE-2026-3449 is a medium-severity denial of service vulnerability in @tootallnate/once, published on 3 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-3449 exists.

Affected packages and fixed versions:
- @tootallnate/once (npm): affected all versions; fixed in 2.0.1
- @tootallnate/once (npm): affected all versions; fixed in 2.0.1
- @tootallnate/once (npm): affected from 3.0.0; fixed in 3.0.1
- @tootallnate/once (npm): affected from 3.0.0; fixed in 3.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-3449/ (Markdown: https://insights.sbomify.com/CVE-2026-3449/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-3449
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-3449
- OSV: https://osv.dev/vulnerability/CVE-2026-3449

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-3449/
Summaries are generated and may contain mistakes; the official description above is the record.
