# CVE-2026-34500: Apache Tomcat: OCSP checks sometimes soft-fail with FFM even when soft-fail is disabled

> Attackers can bypass client certificate authentication in Apache Tomcat when OCSP soft-fail is disabled but FFM is used.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Apr 2026
- **Updated:** 10 Apr 2026
- **Also known as:** BIT-tomcat-2026-34500, CLEANSTART-2026-SZ16719, DEBIAN-CVE-2026-34500, GHSA-24j9-x2wg-9qv6, ROOT-APP-MAVEN-CVE-2026-34500, UBUNTU-CVE-2026-34500

## What is CVE-2026-34500?

CVE-2026-34500 is a medium-severity authentication bypass vulnerability in Apache Tomcat, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CLIENT_CERT authentication does not fail as expected for some scenarios when soft fail is disabled and FFM is used in Apache Tomcat.

This issue affects Apache Tomcat: from 11.0.0-M14 through 11.0.20, from 10.1.22 through 10.1.53, from 9.0.92 through 9.0.116.

Users are recommended to upgrade to version 11.0.21, 10.1.54 or 9.0.117, which fixes the issue.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-34500?

7 open source packages ship an affected version, including org.apache.tomcat:tomcat-coyote-ffm and tomcat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat:tomcat-coyote-ffm` | Maven | From 10.1.22 | 10.1.54 |
| `org.apache.tomcat:tomcat-coyote-ffm` | Maven | From 10.1.22 | 10.1.54 |
| `org.apache.tomcat:tomcat-coyote-ffm` | Maven | From 11.0.0-M14 | 11.0.21 |
| `org.apache.tomcat:tomcat-coyote-ffm` | Maven | From 11.0.0-M14 | 11.0.21 |
| `org.apache.tomcat:tomcat-coyote-ffm` | Maven | From 9.0.92 | 9.0.117 |
| `org.apache.tomcat:tomcat-coyote-ffm` | Maven | From 9.0.92 | 9.0.117 |
| `tomcat` | Bitnami | From 9.0.92 | 9.0.117, 10.1.54, 11.0.21 |

Products: Apache Tomcat.

## How do I fix CVE-2026-34500?

Upgrade org.apache.tomcat:tomcat-coyote-ffm to a fixed version for your release line: 10.1.54, 11.0.21 or 9.0.117.

## Is CVE-2026-34500 being exploited?

There is no known exploitation of CVE-2026-34500 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34500 and fix it if it is affected.

What it is: CVE-2026-34500 is a medium-severity authentication bypass vulnerability in Apache Tomcat, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-34500 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat:tomcat-coyote-ffm (Maven): affected from 10.1.22; fixed in 10.1.54
- org.apache.tomcat:tomcat-coyote-ffm (Maven): affected from 10.1.22; fixed in 10.1.54
- org.apache.tomcat:tomcat-coyote-ffm (Maven): affected from 11.0.0-M14; fixed in 11.0.21
- org.apache.tomcat:tomcat-coyote-ffm (Maven): affected from 11.0.0-M14; fixed in 11.0.21
- org.apache.tomcat:tomcat-coyote-ffm (Maven): affected from 9.0.92; fixed in 9.0.117
- org.apache.tomcat:tomcat-coyote-ffm (Maven): affected from 9.0.92; fixed in 9.0.117
- tomcat (Bitnami): affected from 9.0.92; fixed in 9.0.117, 10.1.54, 11.0.21

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34500/ (Markdown: https://insights.sbomify.com/CVE-2026-34500/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34500
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34500
- OSV: https://osv.dev/vulnerability/CVE-2026-34500

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34500/
Summaries are generated and may contain mistakes; the official description above is the record.
