CVE-2026-34501 Apache Portable Runtime Utility: Heap buffer overflow in APR redis client

High 7.5 Published Updated

A heap buffer overflow in the APR redis client allows attackers to execute arbitrary code or cause denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-34501?

CVE-2026-34501 is a high-severity memory corruption vulnerability in Apache Portable Runtime Utility, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Heap-based Buffer Overflow vulnerability in Apache Portable Runtime Utility redis client.

This issue affects Apache Portable Runtime Utility: from 1.6.0 through 1.6.3.

Users are recommended to upgrade to version 1.6.4, which fixes the issue.

Weakness: CWE-122

Which versions are affected by CVE-2026-34501?

1 open source package ship an affected version, including apr-util. It affects 1 product.

PackageAffectedFixed in
apr-util BitnamiFrom 1.6.01.6.4

Products include Apache Apr-Util.

How do I fix CVE-2026-34501?

Upgrade apr-util to 1.6.4 or later.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2026-34501 being exploited?

There is no known exploitation of CVE-2026-34501 in the wild and no public exploit code.

Sources

Also known as ALPINE-CVE-2026-34501, AZL-94634, BELL-CVE-2026-34501, BIT-apr-util-2026-34501, DEBIAN-CVE-2026-34501, ECHO-84fd-85d1-59f4 and 2 more.

Is CVE-2026-34501 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free