{"answers":{"affected":"1 open source package ship an affected version, including apr-util. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-34501 in the wild and no public exploit code.","fix":"Upgrade apr-util to 1.6.4 or later.","what":"CVE-2026-34501 is a high-severity memory corruption vulnerability in Apache Portable Runtime Utility, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-34501 and fix it if it is affected.\n\nWhat it is: CVE-2026-34501 is a high-severity memory corruption vulnerability in Apache Portable Runtime Utility, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-34501 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apr-util (Bitnami): affected from 1.6.0; fixed in 1.6.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-34501/ (Markdown: https://insights.sbomify.com/CVE-2026-34501/index.md)","id":"CVE-2026-34501","markdown":"https://insights.sbomify.com/CVE-2026-34501/index.md","name":"CVE-2026-34501","record":{"aliases":["ALPINE-CVE-2026-34501","AZL-94634","BELL-CVE-2026-34501","BIT-apr-util-2026-34501","DEBIAN-CVE-2026-34501","ECHO-84fd-85d1-59f4","GHSA-m335-2qh4-r66x","UBUNTU-CVE-2026-34501"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Portable Runtime Utility","requires_auth":"none","summary":"A heap buffer overflow in the APR redis client allows attackers to execute arbitrary code or cause denial of service.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"apr-util","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-122","name":"Heap-based Buffer Overflow"}],"description":"Heap-based Buffer Overflow vulnerability in Apache Portable Runtime Utility redis client.\n\nThis issue affects Apache Portable Runtime Utility: from 1.6.0 through 1.6.3.\n\nUsers are recommended to upgrade to version 1.6.4, which fixes the issue.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Portable Runtime Utility: Heap buffer overflow in APR redis client","id":"CVE-2026-34501","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"memory_corruption","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Apache Portable Runtime Utility: Heap buffer overflow in APR memcached client","id":"CVE-2026-34502"},"packages":[{"ecosystem":"Bitnami","fixed":["1.6.4"],"introduced":["1.6.0"],"last_affected":[],"package":"apr-util","purl":"pkg:bitnami/apr-util","source":"BIT-apr-util-2026-34501"}],"prev":{"headline":"Apache Tomcat: OCSP checks sometimes soft-fail with FFM even when soft-fail is disabled","id":"CVE-2026-34500"},"products":["Apache Portable Runtime Utility"],"published":"2026-08-06","related":[{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2009-2412","kev_date_added":null,"published":"2009-08-06"},{"cvss_score":9.1,"headline":"Apache Portable Runtime Utility: apr-util XML stack recursion crash","id":"CVE-2026-32327","kev_date_added":null,"published":"2026-08-06"},{"cvss_score":9.1,"headline":"Apache Portable Runtime Utility: SQL Injection in apr_dbd_oracle","id":"CVE-2026-34191","kev_date_added":null,"published":"2026-08-06"},{"cvss_score":7.5,"headline":"Apache Portable Runtime Utility: apr_password_validate() vulnerable to timing attack","id":"CVE-2025-49506","kev_date_added":null,"published":"2026-08-06"},{"cvss_score":7.5,"headline":"Apache Portable Runtime Utility: Heap buffer overflow in APR memcached client","id":"CVE-2026-34502","kev_date_added":null,"published":"2026-08-06"},{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2009-1955","kev_date_added":null,"published":"2009-06-06"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-06","vendors":["Apache Software Foundation"]},"summary":"A heap buffer overflow in the APR redis client allows attackers to execute arbitrary code or cause denial of service.","url":"https://insights.sbomify.com/CVE-2026-34501/"}