# CVE-2026-34538: Apache Airflow: Authorization bypass in DagRun wait endpoint (XCom exposure)

> Users with Viewer role can access sensitive XCom results via the DagRun wait endpoint, bypassing intended read-only restrictions.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Apr 2026
- **Updated:** 9 Apr 2026
- **Also known as:** BIT-airflow-2026-34538, ECHO-1071-fe4c-2ff9, GHSA-r7vr-m4jw-r794, MINI-xhj8-q7cf-g9pr, PYSEC-2026-21

## What is CVE-2026-34538?

CVE-2026-34538 is a medium-severity missing authorization vulnerability in Apache Airflow, published on 9 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Airflow versions 3.0.0 through 3.1.8 DagRun wait endpoint returns XCom result values even to users who only have DAG Run read permissions, such as the Viewer role.This behavior conflicts with the FAB RBAC model, which treats XCom as a separate protected resource, and with the security model documentation that defines the Viewer role as read-only.

Airflow uses the FAB Auth Manager to manage access control on a per-resource basis. The Viewer role is intended to be read-only by default, and the security model documentation defines Viewer users as those who can inspect DAGs without accessing sensitive execution results.

Users are recommended to upgrade to Apache Airflow 3.2.0 which resolves this issue.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere)

## Which versions are affected by CVE-2026-34538?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | From 3.0.0 | 3.2.0 |
| `apache-airflow` | PyPI | From 3.0.0 | 3.2.0 |
| `apache-airflow` | PyPI | From 3.0.0 | 3.2.0 |
| `airflow` | Bitnami | From 3.0.0 | 3.2.0 |

Products: Apache Airflow.

## How do I fix CVE-2026-34538?

Upgrade apache-airflow to 3.2.0 or later.

## Is CVE-2026-34538 being exploited?

There is no known exploitation of CVE-2026-34538 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34538 and fix it if it is affected.

What it is: CVE-2026-34538 is a medium-severity missing authorization vulnerability in Apache Airflow, published on 9 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-34538 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected from 3.0.0; fixed in 3.2.0
- apache-airflow (PyPI): affected from 3.0.0; fixed in 3.2.0
- apache-airflow (PyPI): affected from 3.0.0; fixed in 3.2.0
- airflow (Bitnami): affected from 3.0.0; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34538/ (Markdown: https://insights.sbomify.com/CVE-2026-34538/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34538
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34538
- OSV: https://osv.dev/vulnerability/CVE-2026-34538

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34538/
Summaries are generated and may contain mistakes; the official description above is the record.
