# CVE-2026-34543: OpenEXR: Heap information disclosure in PXR24 decompression via unchecked decompressed size (undo_pxr24_impl)

> Attackers can leak sensitive heap memory information by tricking users into opening malicious EXR files using the OpenEXR library.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Apr 2026
- **Updated:** 2 Apr 2026
- **Also known as:** BELL-CVE-2026-34543, DEBIAN-CVE-2026-34543, GHSA-vc68-257w-m432, JLSEC-2026-145, PYSEC-2026-2850, ROOT-OS-DEBIAN-11-CVE-2026-34543, ROOT-OS-DEBIAN-12-CVE-2026-34543, ROOT-OS-DEBIAN-13-CVE-2026-34543, UBUNTU-CVE-2026-34543

## What is CVE-2026-34543?

CVE-2026-34543 is a high-severity vulnerability in Openexr Openexr, published on 1 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. From version 3.4.0 to before version 3.4.8, sensitive information from heap memory may be leaked through the decoded pixel data (information disclosure). This occurs under default settings; simply reading a malicious EXR file is sufficient to trigger the issue, without any user interaction. This issue has been patched in version 3.4.8.

Weakness: CWE-908 (Use of Uninitialized Resource)

## Which versions are affected by CVE-2026-34543?

7 open source packages ship an affected version, including openexr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openexr` | PyPI | From 3.2.0 to 3.2.6 | None |
| `openexr` | PyPI | From 3.2.0 to 3.2.6 | None |
| `openexr` | PyPI | From 3.2.0 | 3.4.8 |
| `openexr` | PyPI | From 3.3.0 to 3.3.8 | None |
| `openexr` | PyPI | From 3.3.0 to 3.3.8 | None |
| `openexr` | PyPI | From 3.4.0 | 3.4.8 |
| `openexr` | PyPI | From 3.4.0 | 3.4.8 |

Products: Openexr Openexr.

## How do I fix CVE-2026-34543?

Upgrade openexr to 3.4.8 or later.

## Is CVE-2026-34543 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34543 exists.

## Other vulnerabilities in Openexr Openexr

- [CVE-2023-5841](https://insights.sbomify.com/CVE-2023-5841/): OpenEXR Heap Overflow in Scanline Deep Data Parsing (critical 9.1)
- [CVE-2026-41142](https://insights.sbomify.com/CVE-2026-41142/): OpenEXR is Vulnerable to Integer overflow in ImageChannel::resize leads to heap OOB write via OpenEXRUtil public API (high 8.8)
- [CVE-2026-42216](https://insights.sbomify.com/CVE-2026-42216/): OpenEXR: Out-of-bounds read in `IDManifest::init()` during prefix expansion (high 8.8)
- [CVE-2017-9111](https://insights.sbomify.com/CVE-2017-9111/): OpenEXR invalid write (high 8.8)
- [CVE-2017-9113](https://insights.sbomify.com/CVE-2017-9113/): Memory corruption in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34543 and fix it if it is affected.

What it is: CVE-2026-34543 is a high-severity vulnerability in Openexr Openexr, published on 1 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34543 exists.

Affected packages and fixed versions:
- openexr (PyPI): affected from 3.2.0 up to 3.2.6; no fix listed
- openexr (PyPI): affected from 3.2.0 up to 3.2.6; no fix listed
- openexr (PyPI): affected from 3.2.0; fixed in 3.4.8
- openexr (PyPI): affected from 3.3.0 up to 3.3.8; no fix listed
- openexr (PyPI): affected from 3.3.0 up to 3.3.8; no fix listed
- openexr (PyPI): affected from 3.4.0; fixed in 3.4.8
- openexr (PyPI): affected from 3.4.0; fixed in 3.4.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34543/ (Markdown: https://insights.sbomify.com/CVE-2026-34543/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34543
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34543
- OSV: https://osv.dev/vulnerability/CVE-2026-34543

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34543/
Summaries are generated and may contain mistakes; the official description above is the record.
