{"answers":{"affected":"2 open source packages ship an affected version, including mailparser. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-3455 exists.","fix":"Upgrade mailparser to 3.9.3 or later.","what":"CVE-2026-3455 is a medium-severity cross-site scripting vulnerability in mailparser, published on 3 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-3455 and fix it if it is affected.\n\nWhat it is: CVE-2026-3455 is a medium-severity cross-site scripting vulnerability in mailparser, published on 3 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-3455 exists.\n\nAffected packages and fixed versions:\n- mailparser (npm): affected all versions; fixed in 3.9.3\n- mailparser (npm): affected all versions; fixed in 3.9.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-3455/ (Markdown: https://insights.sbomify.com/CVE-2026-3455/index.md)","id":"CVE-2026-3455","markdown":"https://insights.sbomify.com/CVE-2026-3455/index.md","name":"CVE-2026-3455","record":{"aliases":["GHSA-7gmj-h9xc-mcxc","MINI-rqcg-r4jq-pwx8"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js email parser","requires_auth":"none","summary":"An attacker can execute arbitrary scripts in victim browsers via malicious URLs in emails parsed by the mailparser library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"mailparser","vendor":"nodemailer"}],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Versions of the package mailparser before 3.9.3 are vulnerable to Cross-site Scripting (XSS) via the textToHtml() function due to the improper sanitisation of URLs in the email content. An attacker can execute arbitrary scripts in victim browsers by adding extra quote  \" to the URL with embedded malicious JavaScript code.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"mailparser vulnerable to Cross-site Scripting","id":"CVE-2026-3455","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"SQL injection in GeekyBot — AI Copilot, Chatbot, WooCommerce Lead Gen \u0026 Zero-Prompt Content","id":"CVE-2026-3456"},"packages":[{"ecosystem":"npm","fixed":["3.9.3"],"introduced":["0"],"last_affected":[],"package":"mailparser","purl":null,"source":"GHSA-7gmj-h9xc-mcxc"},{"ecosystem":"npm","fixed":["3.9.3"],"introduced":["0"],"last_affected":[],"package":"mailparser","purl":"pkg:npm/mailparser","source":"GHSA-7gmj-h9xc-mcxc"}],"prev":{"headline":"Information disclosure in GenerateBlocks","id":"CVE-2026-3454"},"products":["mailparser"],"published":"2026-03-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-03","vendors":["n/a"]},"summary":"An attacker can execute arbitrary scripts in victim browsers via malicious URLs in emails parsed by the mailparser library.","url":"https://insights.sbomify.com/CVE-2026-3455/"}