# CVE-2026-3455: mailparser vulnerable to Cross-site Scripting

> An attacker can execute arbitrary scripts in victim browsers via malicious URLs in emails parsed by the mailparser library.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Mar 2026
- **Updated:** 3 Mar 2026
- **Also known as:** GHSA-7gmj-h9xc-mcxc, MINI-rqcg-r4jq-pwx8

## What is CVE-2026-3455?

CVE-2026-3455 is a medium-severity cross-site scripting vulnerability in mailparser, published on 3 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Versions of the package mailparser before 3.9.3 are vulnerable to Cross-site Scripting (XSS) via the textToHtml() function due to the improper sanitisation of URLs in the email content. An attacker can execute arbitrary scripts in victim browsers by adding extra quote  " to the URL with embedded malicious JavaScript code.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-3455?

2 open source packages ship an affected version, including mailparser. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mailparser` | npm | All versions | 3.9.3 |
| `mailparser` | npm | All versions | 3.9.3 |

Products: Nodemailer Mailparser.

## How do I fix CVE-2026-3455?

Upgrade mailparser to 3.9.3 or later.

## Is CVE-2026-3455 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-3455 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-3455 and fix it if it is affected.

What it is: CVE-2026-3455 is a medium-severity cross-site scripting vulnerability in mailparser, published on 3 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-3455 exists.

Affected packages and fixed versions:
- mailparser (npm): affected all versions; fixed in 3.9.3
- mailparser (npm): affected all versions; fixed in 3.9.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-3455/ (Markdown: https://insights.sbomify.com/CVE-2026-3455/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-3455
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-3455
- OSV: https://osv.dev/vulnerability/CVE-2026-3455

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-3455/
Summaries are generated and may contain mistakes; the official description above is the record.
