CVE-2026-34573 Parse Server: GraphQL complexity validator exponential fragment traversal DoS
Unauthenticated attackers can cause denial of service via crafted GraphQL queries in Parse Server deployments with specific complexity validation enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-34573?
CVE-2026-34573 is a high-severity denial of service vulnerability in Parseplatform Parse-Server, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.68 and 9.7.0-alpha.12, the GraphQL query complexity validator can be exploited to cause a denial-of-service by sending a crafted query with binary fan-out fragment spreads. A single unauthenticated request can block the Node.js event loop for seconds, denying service to all concurrent users. This only affects deployments that have enabled the requestComplexity.graphQLDepth or requestComplexity.graphQLFields configuration options. This issue has been patched in versions 8.6.68 and 9.7.0-alpha.12.
Weakness: CWE-407
Which versions are affected by CVE-2026-34573?
5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
parse-server npm | All versions | 8.6.68 |
parse-server npm | All versions | 8.6.68 |
parse-server npm | From 9.0.0 | 9.7.0-alpha.12 |
parse-server npm | From 9.0.0 | 9.7.0-alpha.12 |
parse Bitnami | All versions | 8.6.68, 9.7.0 |
Products include Parseplatform Parse-Server.
How do I fix CVE-2026-34573?
Upgrade parse-server to a fixed version for your release line: 8.6.68 or 9.7.0-alpha.12.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-34573 being exploited?
There is no known exploitation of CVE-2026-34573 in the wild and no public exploit code.
Other vulnerabilities in Parseplatform Parse-Server
- CVE-2026-30966 Parse Server role escalation and CLP bypass via direct `_Join` table write
- CVE-2024-27298 Parse Server literalizeRegexPart SQL Injection
- CVE-2022-24760 Command Injection in Parse server
- CVE-2026-30965 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter
- CVE-2023-36475 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution
Sources
Also known as BIT-parse-2026-34573, GHSA-mfj6-6p54-m98c.