# CVE-2026-34578: OPNsense has an LDAP Injection via Unsanitized Username in Authentication

> Unauthenticated attackers can inject LDAP filters to enumerate users or bypass group restrictions in OPNsense firewall authentication.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Apr 2026
- **Updated:** 9 Apr 2026
- **Also known as:** GHSA-jpm7-f59c-mp54

## What is CVE-2026-34578?

CVE-2026-34578 is a high-severity vulnerability in opnsense core, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OPNsense is a FreeBSD based firewall and routing platform. Prior to 26.1.6, OPNsense's LDAP authentication connector passes the login username directly into an LDAP search filter without calling ldap_escape(). An unauthenticated attacker can inject LDAP filter metacharacters into the username field of the WebGUI login page to enumerate valid LDAP usernames in the configured directory. When the LDAP server configuration includes an Extended Query to restrict login to members of a specific group, the same injection can be used to bypass that group membership restriction and authenticate as any LDAP user whose password is known, regardless of group membership. This vulnerability is fixed in 26.1.6.

Weakness: CWE-90 (Improper Neutralization of Special Elements used in an LDAP Query)

## Which versions are affected by CVE-2026-34578?

It affects 1 product.


Products: Opnsense Opnsense.

## How do I fix CVE-2026-34578?

No fix has been published for CVE-2026-34578 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-34578 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34578 exists.

## Other vulnerabilities in opnsense core

- [CVE-2023-27152](https://insights.sbomify.com/CVE-2023-27152/): Auth bypass in n/a (critical 9.8)
- [CVE-2023-39001](https://insights.sbomify.com/CVE-2023-39001/): Command injection in n/a (critical 9.8)
- [CVE-2023-39004](https://insights.sbomify.com/CVE-2023-39004/): Information disclosure in n/a (critical 9.8)
- [CVE-2023-39008](https://insights.sbomify.com/CVE-2023-39008/): Command injection in n/a (critical 9.8)
- [CVE-2023-39007](https://insights.sbomify.com/CVE-2023-39007/): Cross-site scripting in n/a (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34578 and fix it if it is affected.

What it is: CVE-2026-34578 is a high-severity vulnerability in opnsense core, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34578 exists.

Affected product: opnsense core. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34578/ (Markdown: https://insights.sbomify.com/CVE-2026-34578/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34578
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34578
- OSV: https://osv.dev/vulnerability/CVE-2026-34578

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34578/
Summaries are generated and may contain mistakes; the official description above is the record.
