CVE-2026-34587 Kirby has Server-Side Template Injection (SSTI) via double template resolution in option rendering

High 7.6 Published Updated

Authenticated attackers with page creation permissions can bypass editorial workflows to publish pages directly via the REST API.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-34587?

CVE-2026-34587 is a high-severity missing authorization vulnerability in getkirby kirby, published on 24 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Kirby is an open-source content management system. Prior to versions 4.9.0 and 5.4.0, Kirby's user permissions control which user role is allowed to perform specific actions to content models in the CMS. These permissions are defined for each role in the user blueprint (`site/blueprints/users/...`). It is also possible to customize the permissions for each target model in the model blueprints (such as in `site/blueprints/pages/...`) using the `options` feature. The permissions and options together control the authorization of user actions. For pages, Kirby provides the `pages.create` and `pages.changeStatus` permissions (among others). In affected releases, Kirby checked these permissions independently and only for the respective action. However the `changeStatus` permission didn't take effect on page creation. New pages are created as drafts by default and need to be published by changing the page status of an existing page draft. This is ensured when the page is created via the Kirby Panel. However the REST API allows to override the `isDraft` flag when creating a new page. This allowed authenticated attackers with the `pages.create` permission to immediately create published pages, bypassing the normal editorial workflow. The problem has been patched in Kirby 4.9.0 and Kirby 5.4.0. Kirby has updated the `Options` logic to no longer double-resolve queries in option values coming from `OptionsQuery` or `OptionsApi` sources. Kirby now only resolves queries that are directly configured in the blueprints.

Weakness: CWE-1336

Which versions are affected by CVE-2026-34587?

4 open source packages ship an affected version, including getkirby/cms. It affects 1 product.

PackageAffectedFixed in
getkirby/cms PackagistAll versions4.9.0
getkirby/cms PackagistAll versions4.9.0
getkirby/cms PackagistFrom 5.0.05.4.0
getkirby/cms PackagistFrom 5.0.05.4.0

Products include Getkirby Kirby.

How do I fix CVE-2026-34587?

Upgrade getkirby/cms to a fixed version for your release line: 4.9.0 or 5.4.0.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-34587 being exploited?

There is no known exploitation of CVE-2026-34587 in the wild and no public exploit code.

Sources

Also known as GHSA-jcjw-58rv-c452.

Is CVE-2026-34587 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free