CVE-2026-34589 OpenEXR: DWA Lossy Decoder Heap Out-of-Bounds Write
An integer overflow in the OpenEXR DWA decoder allows heap out-of-bounds writes, potentially leading to code execution or crashes when processing malicious images.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-34589?
CVE-2026-34589 is a high-severity vulnerability in Openexr Openexr, published on 6 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. From 3.2.0 to before 3.2.7, 3.3.9, and 3.4.9, the DWA lossy decoder constructs temporary per-component block pointers using signed 32-bit arithmetic. For a large enough width, the calculation overflows and later decoder stores operate on a wrapped pointer outside the allocated rowBlock backing store. This vulnerability is fixed in 3.2.7, 3.3.9, and 3.4.9.
Which versions are affected by CVE-2026-34589?
7 open source packages ship an affected version, including openexr and OpenEXR. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
openexr PyPI | From 3.2.0 | 3.2.7, 3.3.9, 3.4.9 |
openexr PyPI | From 3.2.0 | 3.2.7 |
openexr PyPI | From 3.3.0 | 3.3.9 |
openexr PyPI | From 3.4.0 | 3.4.9 |
OpenEXR PyPI | From 3.2.0 | 3.2.7 |
OpenEXR PyPI | From 3.3.0 | 3.3.9 |
1 more packages
OpenEXR PyPI | From 3.4.0 | 3.4.9 |
Products include Openexr Openexr.
How do I fix CVE-2026-34589?
Upgrade openexr to a fixed version for your release line: 3.2.7, 3.3.9 or 3.4.9.
Is CVE-2026-34589 being exploited?
There is no known exploitation of CVE-2026-34589 in the wild and no public exploit code.
Other vulnerabilities in Openexr Openexr
- CVE-2023-5841 OpenEXR Heap Overflow in Scanline Deep Data Parsing
- CVE-2026-41142 OpenEXR is Vulnerable to Integer overflow in ImageChannel::resize leads to heap OOB write via OpenEXRUtil public API
- CVE-2026-42216 OpenEXR: Out-of-bounds read in `IDManifest::init()` during prefix expansion
- CVE-2017-9111 OpenEXR invalid write
- CVE-2017-9113 Memory corruption in n/a
Sources
Also known as BELL-CVE-2026-34589, DEBIAN-CVE-2026-34589, GHSA-p8xc-w3q4-h64x, JLSEC-2026-149, PYSEC-2026-2848, ROOT-OS-DEBIAN-11-CVE-2026-34589 and 3 more.