# CVE-2026-34589: OpenEXR: DWA Lossy Decoder Heap Out-of-Bounds Write

> An integer overflow in the OpenEXR DWA decoder allows heap out-of-bounds writes, potentially leading to code execution or crashes when processing malicious images.

- **Severity:** High 8.4 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Apr 2026
- **Updated:** 15 Jul 2026
- **Also known as:** BELL-CVE-2026-34589, DEBIAN-CVE-2026-34589, GHSA-p8xc-w3q4-h64x, JLSEC-2026-149, PYSEC-2026-2848, ROOT-OS-DEBIAN-11-CVE-2026-34589, ROOT-OS-DEBIAN-12-CVE-2026-34589, ROOT-OS-DEBIAN-13-CVE-2026-34589, UBUNTU-CVE-2026-34589

## What is CVE-2026-34589?

CVE-2026-34589 is a high-severity vulnerability in Openexr Openexr, published on 6 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. From 3.2.0 to before 3.2.7, 3.3.9, and 3.4.9, the DWA lossy decoder constructs temporary per-component block pointers using signed 32-bit arithmetic. For a large enough width, the calculation overflows and later decoder stores operate on a wrapped pointer outside the allocated rowBlock backing store. This vulnerability is fixed in 3.2.7, 3.3.9, and 3.4.9.

Weakness: CWE-787 (Out-of-bounds Write), CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2026-34589?

7 open source packages ship an affected version, including openexr and OpenEXR. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openexr` | PyPI | From 3.2.0 | 3.2.7, 3.3.9, 3.4.9 |
| `openexr` | PyPI | From 3.2.0 | 3.2.7 |
| `openexr` | PyPI | From 3.3.0 | 3.3.9 |
| `openexr` | PyPI | From 3.4.0 | 3.4.9 |
| `OpenEXR` | PyPI | From 3.2.0 | 3.2.7 |
| `OpenEXR` | PyPI | From 3.3.0 | 3.3.9 |
| `OpenEXR` | PyPI | From 3.4.0 | 3.4.9 |

Products: Openexr Openexr.

## How do I fix CVE-2026-34589?

Upgrade openexr to a fixed version for your release line: 3.2.7, 3.3.9 or 3.4.9.

## Is CVE-2026-34589 being exploited?

There is no known exploitation of CVE-2026-34589 in the wild and no public exploit code.

## Other vulnerabilities in Openexr Openexr

- [CVE-2023-5841](https://insights.sbomify.com/CVE-2023-5841/): OpenEXR Heap Overflow in Scanline Deep Data Parsing (critical 9.1)
- [CVE-2026-41142](https://insights.sbomify.com/CVE-2026-41142/): OpenEXR is Vulnerable to Integer overflow in ImageChannel::resize leads to heap OOB write via OpenEXRUtil public API (high 8.8)
- [CVE-2026-42216](https://insights.sbomify.com/CVE-2026-42216/): OpenEXR: Out-of-bounds read in `IDManifest::init()` during prefix expansion (high 8.8)
- [CVE-2017-9111](https://insights.sbomify.com/CVE-2017-9111/): OpenEXR invalid write (high 8.8)
- [CVE-2017-9113](https://insights.sbomify.com/CVE-2017-9113/): Memory corruption in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34589 and fix it if it is affected.

What it is: CVE-2026-34589 is a high-severity vulnerability in Openexr Openexr, published on 6 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-34589 in the wild and no public exploit code.

Affected packages and fixed versions:
- openexr (PyPI): affected from 3.2.0; fixed in 3.2.7, 3.3.9, 3.4.9
- openexr (PyPI): affected from 3.2.0; fixed in 3.2.7
- openexr (PyPI): affected from 3.3.0; fixed in 3.3.9
- openexr (PyPI): affected from 3.4.0; fixed in 3.4.9
- OpenEXR (PyPI): affected from 3.2.0; fixed in 3.2.7
- OpenEXR (PyPI): affected from 3.3.0; fixed in 3.3.9
- OpenEXR (PyPI): affected from 3.4.0; fixed in 3.4.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34589/ (Markdown: https://insights.sbomify.com/CVE-2026-34589/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34589
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34589
- OSV: https://osv.dev/vulnerability/CVE-2026-34589

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34589/
Summaries are generated and may contain mistakes; the official description above is the record.
