# CVE-2026-34591: Poetry Has Wheel Path Traversal Which Can Lead to Arbitrary File Write

> Attackers can write arbitrary files via crafted wheel packages, potentially compromising the system where Poetry is installed.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Apr 2026
- **Updated:** 3 Apr 2026
- **Also known as:** AZL-81899, DEBIAN-CVE-2026-34591, GHSA-2599-h6xx-hpxp, MINI-5vc4-rxj2-hq3j, PYSEC-2026-2260, ROOT-APP-PYPI-CVE-2026-34591, UBUNTU-CVE-2026-34591

## What is CVE-2026-34591?

CVE-2026-34591 is a high-severity path traversal vulnerability in python-poetry poetry, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Poetry is a dependency manager for Python. From version 1.4.0 to before version 2.3.3, a crafted wheel can contain ../ paths that Poetry writes to disk without containment checks, allowing arbitrary file write with the privileges of the Poetry process. It is reachable from untrusted package artifacts during normal install flows. (Normally, installing a malicious wheel is not sufficient for execution of malicious code. Malicious code will only be executed after installation if the malicious package is imported or invoked by the user.). This issue has been patched in version 2.3.3.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-34591?

3 open source packages ship an affected version, including poetry. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `poetry` | PyPI | From 1.4.0 | 2.3.3 |
| `poetry` | PyPI | From 1.4.0 | 2.3.3 |
| `poetry` | PyPI | From 1.4.0 | 2.3.3 |

Products: Python-Poetry Poetry.

## How do I fix CVE-2026-34591?

Upgrade poetry to 2.3.3 or later.

## Is CVE-2026-34591 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34591 exists.

## Other vulnerabilities in python-poetry poetry

- [CVE-2022-26184](https://insights.sbomify.com/CVE-2022-26184/): Poetry before v1.1.9 contains Untrusted Search Path (critical 9.8)
- [CVE-2022-36069](https://insights.sbomify.com/CVE-2022-36069/): Poetry Argument Injection vulnerability can lead to local Code Execution (high 7.3)
- [CVE-2022-36070](https://insights.sbomify.com/CVE-2022-36070/): Poetry's Untrusted Search Path can lead to Local Code Execution on Windows (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34591 and fix it if it is affected.

What it is: CVE-2026-34591 is a high-severity path traversal vulnerability in python-poetry poetry, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34591 exists.

Affected packages and fixed versions:
- poetry (PyPI): affected from 1.4.0; fixed in 2.3.3
- poetry (PyPI): affected from 1.4.0; fixed in 2.3.3
- poetry (PyPI): affected from 1.4.0; fixed in 2.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34591/ (Markdown: https://insights.sbomify.com/CVE-2026-34591/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34591
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34591
- OSV: https://osv.dev/vulnerability/CVE-2026-34591

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34591/
Summaries are generated and may contain mistakes; the official description above is the record.
