# CVE-2026-34598: YesWiki has Persistant Blind XSS at "/?BazaR&vue=consulter"

> Attackers can inject persistent JavaScript via form titles in YesWiki, leading to code execution or account takeover when users view the page.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Apr 2026
- **Updated:** 2 Apr 2026
- **Also known as:** GHSA-37fq-47qj-6j5j

## What is CVE-2026-34598?

CVE-2026-34598 is a high-severity cross-site scripting vulnerability in yeswiki, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

YesWiki is a wiki system written in PHP. Prior to version 4.6.0, a stored and blind XSS vulnerability exists in the form title field. A malicious attacker can inject JavaScript without any authentication via a form title that is saved in the backend database. When any user visits that injected page, the JavaScript payload gets executed. This issue has been patched in version 4.6.0.

Weakness: CWE-87 (Improper Neutralization of Alternate XSS Syntax), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-34598?

2 open source packages ship an affected version, including yeswiki/yeswiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yeswiki/yeswiki` | Packagist | All versions | 4.6.0 |
| `yeswiki/yeswiki` | Packagist | All versions | 4.6.0 |

Products: Yeswiki Yeswiki.

## How do I fix CVE-2026-34598?

Upgrade yeswiki/yeswiki to 4.6.0 or later.

## Is CVE-2026-34598 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34598 exists.

## Other vulnerabilities in yeswiki

- [CVE-2025-46348](https://insights.sbomify.com/CVE-2025-46348/): YesWiki Vulnerable to Unauthenticated Site Backup Creation and Download (critical 10.0)
- [CVE-2024-51478](https://insights.sbomify.com/CVE-2024-51478/): Use of a Broken or Risky Cryptographic Algorithm in YesWiki (critical 9.9)
- [CVE-2018-1000641](https://insights.sbomify.com/CVE-2018-1000641/): Deserialization in n/a (critical 9.8)
- [CVE-2025-31131](https://insights.sbomify.com/CVE-2025-31131/): Path Traversal allowing arbitrary read of files in Yeswiki (high 8.6)
- [CVE-2025-46349](https://insights.sbomify.com/CVE-2025-46349/): YesWiki Vulnerable to Unauthenticated Reflected Cross-site Scripting (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34598 and fix it if it is affected.

What it is: CVE-2026-34598 is a high-severity cross-site scripting vulnerability in yeswiki, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34598 exists.

Affected packages and fixed versions:
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.6.0
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34598/ (Markdown: https://insights.sbomify.com/CVE-2026-34598/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34598
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34598
- OSV: https://osv.dev/vulnerability/CVE-2026-34598

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34598/
Summaries are generated and may contain mistakes; the official description above is the record.
