CVE-2026-34601 xmldom: XML injection via unsafe CDATA serialization allows attacker-controlled markup insertion
Attackers can inject malicious XML markup via CDATA sections in xmldom, potentially leading to code execution or data manipulation.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-34601?
CVE-2026-34601 is a high-severity vulnerability in xmldom, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) `DOMParser` and `XMLSerializer` module. In xmldom versions 0.6.0 and prior and @xmldom/xmldom prior to versions 0.8.12 and 0.9.9, xmldom/xmldom allows attacker-controlled strings containing the CDATA terminator ]]> to be inserted into a CDATASection node. During serialization, XMLSerializer emitted the CDATA content verbatim without rejecting or safely splitting the terminator. As a result, data intended to remain text-only became active XML markup in the serialized output, enabling XML structure injection and downstream business-logic manipulation. This issue has been patched in xmldom version 0.6.0 and @xmldom/xmldom versions 0.8.12 and 0.9.9.
Weakness: CWE-91
Which versions are affected by CVE-2026-34601?
6 open source packages ship an affected version, including @xmldom/xmldom and xmldom.
| Package | Affected | Fixed in |
|---|---|---|
@xmldom/xmldom npm | All versions | 0.8.12 |
@xmldom/xmldom npm | All versions | 0.8.12 |
@xmldom/xmldom npm | From 0.9.0 | 0.9.9 |
@xmldom/xmldom npm | From 0.9.0 | 0.9.9 |
xmldom npm | All versions to 0.6.0 | None |
xmldom npm | All versions to 0.6.0 | None |
Linux distribution packages (2)
heroic-games-launcher openSUSE:Tumbleweed | All versions | 2.20.1-5.1 |
python-jupyterlab-templates openSUSE:Tumbleweed | All versions | 0.5.3-1.1 |
How do I fix CVE-2026-34601?
Upgrade @xmldom/xmldom to a fixed version for your release line: 0.8.12 or 0.9.9.
Is CVE-2026-34601 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34601 exists.
Sources
Also known as CLEANSTART-2026-IX02906, CLEANSTART-2026-LQ57257, CLSA-2026-1791987635, DEBIAN-CVE-2026-34601, ECHO-0153-0abd-631e, GHSA-wh4c-j3r5-mjhp and 7 more.