# CVE-2026-34601: xmldom: XML injection via unsafe CDATA serialization allows attacker-controlled markup insertion

> Attackers can inject malicious XML markup via CDATA sections in xmldom, potentially leading to code execution or data manipulation.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Apr 2026
- **Updated:** 15 Jul 2026
- **Also known as:** CLEANSTART-2026-IX02906, CLEANSTART-2026-LQ57257, CLSA-2026-1791987635, DEBIAN-CVE-2026-34601, ECHO-0153-0abd-631e, GHSA-wh4c-j3r5-mjhp, MINI-38cq-6p3q-g5x3, MINI-8rh8-2f35-8xrm, MINI-p983-g8gf-pwvc, ROOT-APP-NPM-CVE-2026-34601, UBUNTU-CVE-2026-34601, openSUSE-SU-2026:10497-1, openSUSE-SU-2026:10506-1

## What is CVE-2026-34601?

CVE-2026-34601 is a high-severity vulnerability in xmldom, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) `DOMParser` and `XMLSerializer` module. In xmldom versions 0.6.0 and prior and @xmldom/xmldom prior to versions 0.8.12 and 0.9.9, xmldom/xmldom allows attacker-controlled strings containing the CDATA terminator ]]> to be inserted into a CDATASection node. During serialization, XMLSerializer emitted the CDATA content verbatim without rejecting or safely splitting the terminator. As a result, data intended to remain text-only became active XML markup in the serialized output, enabling XML structure injection and downstream business-logic manipulation. This issue has been patched in xmldom version 0.6.0 and @xmldom/xmldom versions 0.8.12 and 0.9.9.

Weakness: CWE-91 (XML Injection)

## Which versions are affected by CVE-2026-34601?

6 open source packages ship an affected version, including @xmldom/xmldom and xmldom.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@xmldom/xmldom` | npm | All versions | 0.8.12 |
| `@xmldom/xmldom` | npm | All versions | 0.8.12 |
| `@xmldom/xmldom` | npm | From 0.9.0 | 0.9.9 |
| `@xmldom/xmldom` | npm | From 0.9.0 | 0.9.9 |
| `xmldom` | npm | All versions to 0.6.0 | None |
| `xmldom` | npm | All versions to 0.6.0 | None |
| `heroic-games-launcher` | openSUSE:Tumbleweed | All versions | 2.20.1-5.1 |
| `python-jupyterlab-templates` | openSUSE:Tumbleweed | All versions | 0.5.3-1.1 |

## How do I fix CVE-2026-34601?

Upgrade @xmldom/xmldom to a fixed version for your release line: 0.8.12 or 0.9.9.

## Is CVE-2026-34601 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34601 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34601 and fix it if it is affected.

What it is: CVE-2026-34601 is a high-severity vulnerability in xmldom, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34601 exists.

Affected packages and fixed versions:
- @xmldom/xmldom (npm): affected all versions; fixed in 0.8.12
- @xmldom/xmldom (npm): affected all versions; fixed in 0.8.12
- @xmldom/xmldom (npm): affected from 0.9.0; fixed in 0.9.9
- @xmldom/xmldom (npm): affected from 0.9.0; fixed in 0.9.9
- xmldom (npm): affected all versions up to 0.6.0; no fix listed
- xmldom (npm): affected all versions up to 0.6.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34601/ (Markdown: https://insights.sbomify.com/CVE-2026-34601/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34601
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34601
- OSV: https://osv.dev/vulnerability/CVE-2026-34601

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34601/
Summaries are generated and may contain mistakes; the official description above is the record.
