CVE-2026-34606 Stored XSS in Frappe LMS

Medium 6.9 Published Updated

Stored XSS in Frappe LMS allows attackers to inject malicious scripts, potentially leading to code execution or account takeover.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-34606?

CVE-2026-34606 is a medium-severity cross-site scripting vulnerability in frappe lms, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Frappe Learning Management System (LMS) is a learning system that helps users structure their content. From version 2.27.0 to before version 2.48.0, Frappe LMS was vulnerable to stored XSS. This issue has been patched in version 2.48.0.

Weakness: CWE-79

Which versions are affected by CVE-2026-34606?

It affects 1 product.

Products include Frappe Learning.

How do I fix CVE-2026-34606?

No fix has been published for CVE-2026-34606 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-34606 being exploited?

There is no known exploitation of CVE-2026-34606 in the wild and no public exploit code.

Sources

Also known as GHSA-qf5w-r34q-c7j2.

Is CVE-2026-34606 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free